with the root user i can able to start OD..but with bootstrap user i am not...any idea why?
I am also getting the same error even with Administrator account on Windows system.Please let us know the resolution for this problem.Thanks,Murali
BEGIN LOG: Logfile [/od-home/OpenDeployNG/log/odreceiverServer_odrcvr.log] ---------SVR: 2009-09-23 15:37:33 EDT GMT+01:00 Begin initialization of OpenDeploy server.SVR: 2009-09-23 15:37:33 EDT GMT-04:00 Version: 6.2.1.0.0 Build 71309 Interwoven 20081020SVR: 2009-09-23 15:37:33 EDT GMT-04:00 Using time zone: Eastern Daylight TimeSVR: 2009-09-23 15:37:33 EDT GMT-04:00 Using locale: en_USSVR: 2009-09-23 15:37:33 EDT GMT-04:00 Using file encoding: UTF-8SVR: 2009-09-23 15:37:33 EDT GMT-04:00 Using OpenDeploy home directory: /od-home/OpenDeployNGSVR: 2009-09-23 15:37:33 EDT GMT-04:00 Got arguments: /od-home/OpenDeployNG/etc/deploy.cfgSVR: 2009-09-23 15:37:33 EDT GMT-04:00 Reading configuration file: /od-home/OpenDeployNG/etc/deploy.cfgSVR: 2009-09-23 15:37:34 EDT GMT-04:00 Loading library iwdeploy_hopiSVR: 2009-09-23 15:37:34 EDT GMT-04:00 SVR: 2009-09-23 15:37:34 EDT GMT-04:00 deploy.cfg Deploy.licCustomerID property no specified.SVR: 2009-09-23 15:37:34 EDT GMT-04:00--Permanent License --License InformationDomain : someDomainHostname : odreceiverServerProduct : ODServer Type : OpenDeploy Development ServerBase Server : falsePlatform : LinuxO/S version : nullDataDeploy : trueIntelligientDelivery: nullArchival : nullCustomer ID : nullExpiration : NoLimits-----------------SVR: 2009-09-23 15:37:34 EDT GMT-04:00 RMI server binding hostname/IP address not requested in deploy.cfg file.SVR: 2009-09-23 15:37:34 EDT GMT-04:00 Will use default which is the local hostname.SVR: 2009-09-23 15:37:34 EDT GMT-04:00 RMI server binding hostname/IP address in Java property is null.SVR: 2009-09-23 15:37:34 EDT GMT-04:00 Using server config file specified in deploy.cfg: /od-home/OpenDeployNG/etc/odrcvr.xmls.xmlSVR: 2009-09-23 15:37:34 EDT GMT-04:00 Using server log directory /od-home/OpenDeployNG/log specified in server config file.SVR: 2009-09-23 15:37:34 EDT GMT-04:00 Using OpenDeploy Server log file: /od-home/OpenDeployNG/log/odreceiverServer_odrcvr.logSVR: 2009-09-23 15:37:34 EDT GMT-04:00 Using default locale directory location: /od-home/OpenDeployNG/lib/localeSVR: 2009-09-23 15:37:34 EDT GMT-04:00 Got bootstrap user name from deploy.cfg file: svcODReceiverSVR: 2009-09-23 15:37:34 EDT GMT-04:00 Using deploy.cfg allowDefaultBootStrapUser default setting: yesSVR: 2009-09-23 15:37:34 EDT GMT-04:00 Initialize OpenDeploy security component.SEC: 2009-09-23 15:37:35 EDT GMT-04:00 Detected a role DB in file /od-home/OpenDeployNG/db/od-adminSEC: 2009-09-23 15:37:35 EDT GMT-04:00 Successfully read role DB from file /od-home/OpenDeployNG/db/od-admindd.SEC: 2009-09-23 15:37:35 EDT GMT-04:00 Successfully created OpenDeploy Admin Role database.SEC: 2009-09-23 15:37:35 EDT GMT-04:00 Detected a role DB in file /od-home/OpenDeployNG/db/od-userSEC: 2009-09-23 15:37:35 EDT GMT-04:00 Successfully read role DB from file /od-home/OpenDeployNG/db/od-userSEC: 2009-09-23 15:37:35 EDT GMT-04:00 Successfully created OpenDeploy User role database.SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Starting OpenDeploy security component.SVR: 2009-09-23 15:37:35 EDT GMT-04:00 *** OpenDeploy security component started. ***SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Deploy.accessKeyFile specified in deploy.cfg file.SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Using access Key filename passphraseSVR: 2009-09-23 15:37:35 EDT GMT-04:00 Deploy.useAccessKeyFileForAdmin specified in deploy.cfg file is = ySVR: 2009-09-23 15:37:35 EDT GMT-04:00 useAccessKeyFileForAdmin is trueSVR: 2009-09-23 15:37:35 EDT GMT-04:00 Get any RMI connection ports specified in the deploy.cfg fileSVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort1: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort2: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort3: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort4: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort5: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort6: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort7: 24071SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort8: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort9: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort10: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort11: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort12: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort13: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort14: 24078SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Got Deploy.rmiConnectionPort15: 24078nd 2407124078 and 24078SVR 06000: 2009-09-23 15:37:35 EDT GMT-04:00 Starting OpenDeploy RMI registry on port '9173'.SVR 06001: 2009-09-23 15:37:35 EDT GMT-04:00 OpenDeploy RMI registry started.SVR: 2009-09-23 15:37:35 EDT GMT-04:00 Initialize OpenDeploy engine component.ENG: 2009-09-23 15:37:35 EDT GMT-04:00 Instantiating the OpenDeploy Server engineENG: 2009-09-23 15:37:35 EDT GMT-04:00 Component Version : 6.2.1.0.0 Build 71309 Interwoven 20081020ENG: 2009-09-23 15:37:35 EDT GMT-04:00 *** I18N initialization done ***ENG: 2009-09-23 15:37:35 EDT GMT-04:00 *** Start access setup ***ENG: 2009-09-23 15:37:35 EDT GMT-04:00 Access key file /od-home/OpenDeployNG/etc/passphrase does not exist.ENG: 2009-09-23 15:37:35 EDT GMT-04:00 *** Not doing access setup ***ENG: 2009-09-23 15:37:35 EDT GMT-04:00 *** useAccessKeyFileForAdmin is trueENG: 2009-09-23 15:37:36 EDT GMT-04:00 *** Archival module is not configured. It will not be enabled. ***ENG: 2009-09-23 15:37:36 EDT GMT-04:00 *** DataDeploy module not enabled ***ENG: 2009-09-23 15:37:36 EDT GMT-04:00 *** OpenDeploy Server is NOT a sender ***ENG: 2009-09-23 15:37:36 EDT GMT-04:00 *** OpenDeploy Server is a receiver ***ENG: 2009-09-23 15:37:36 EDT GMT-04:00 Listener completed sessions capacity = 50ENG: 2009-09-23 15:37:36 EDT GMT-04:00 Path registry checking: falseENG: 2009-09-23 15:37:36 EDT GMT-04:00 *** Fan-out capability enabled ***SVR: 2009-09-23 15:37:36 EDT GMT-04:00 Starting OpenDeploy engine component.ENG: 2009-09-23 15:37:36 EDT GMT-04:00 ***ERROR - Exception: CONFIG_FILE.message: CONFIG_FILE.Details: File not foundat com.interwoven.deploy.adapters.od.TNewToOldRx.convert(TNewToOldRx.java:98)at com.interwoven.deploy.adapters.od.TNewToOldRx.convert(TNewToOldRx.java:63)at com.interwoven.deploy.engine.TMacroDeployReceiver.start(TMacroDeployReceiver.java:186)at com.interwoven.deploy.engine.TDeploySvrEngine.start(TDeploySvrEngine.java:1601)at com.interwoven.deploy.cdmain.IWCDMain.main(IWCDMain.java:1765)at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)at java.lang.reflect.Method.invoke(Method.java:585)at com.interwoven.deploy.cdmain.IWCDBoot.run(IWCDBoot.java:255)at java.lang.Thread.run(Thread.java:595)SVR: 2009-09-23 15:37:36 EDT GMT-04:00 ***ERROR - OpenDeploy engine component encountered error.SVR: 2009-09-23 15:37:36 EDT GMT-04:00 ERROR DETAILS:Failed to start OpenDeploy receiver.error caught:CONFIG_FILE.SVR: 2009-09-23 15:37:36 EDT GMT-04:00 Bring up of OpenDeploy server FAILED.
Thanks Ghoti. I re-ran the iwodnonroot clt and that did the trick.Of note though, I did have to add the line> /etc/init.d/iwod60 stop in the iwod60_boot_wrap to ensure that opendeploy was, in fact, stopped before trying to start it as the non-root user.For whatever reason, the kill command was not being picked up in the rc2.d/k80iwod60 script.Thanks again.