Home Documentum

xCP auto activitity

Hello,
We have upgraded our environment from 6.7 to 16.4 P20. We have developed an xCP application in xCP 16.1.7.
In our environment, the application doesn't want to create a folder, which is the first auto activity on the workflow.

If we run the process in xCP Designer on debug mode everything works perfectly the folder gets created in the cabinet.
But when we run the application on the browser, the folder never gets created.
When we check workflow reporting in DA, the workflow shows as running and all the tasks status show as Future.

We have opened a ticket with Opentext but it's been five days now, they keep asking for more logs to analyze without a solution.
When OpenText engineers run our application on their environment everything works accordingly.

I ran : http://:/bpm/servlet/DoMethod and it shows that the Java Method is running.
I have also ran these two API's with no issues
API>retrieve,c,dm_method where object_name = 'BPSIntegration'
API>apply,c,NULL,DO_METHOD,METHOD,S,BPSIntegration

What could be the problem and how do we resolve this issue?

Comments

  • Have you tried to reconfigure your auto activity to use new activity templates?

  • Hello,
    Yes, I have tried to delete and put a new auto activity and that did not help.
    I've also tried putting a manual activity as the first activity to test, when I do that the workflow does get to the manual activity but not to the auto activity.
    I have also tried putting a different activity, Execute Java Service it behaved the same as the Create activity.

  • Since you can run your code locally on xcp designer correctly, this means its actually deployment of the code that is causing the problem. How are you deploying your code (to create folder)? If this is jar, are you using java module to deploy it or are you deploying it directly to JMS dba/java_methods dir?

  • I am deploying it straight from xCP designer using xCP Deployment Agent (xDA).

    I do not think it has something to do with the way I deploy the application, because like I said if I put a manual activity just before an auto activity the manual step works fine in xCP designer debug mode and outside(on the browser)

    I suspect the issue has something to do with processing auto activities outside the xCP Designer debug mode

  • Have you logged a ticket with Support yet? This could be a bug. We recently found a bug after upgrading our 7.3 xcp to 16.4 that has to do with radio buttons.

  • Yes we have logged a call a week ago, they keep coming back and collecting logs.
    Today we had a WebEx session with SME guys and collected more logs.

Sign In or Register to comment.