Home AppWorks

Web Service Test Operation - Why default SOAP Request has no correct parameter tag name?

I tried many times to create an Web service based on Java Class Metadata with  specifically defined parameters in Method Properties window. Checked XML Node for datatypes that are int(i4).  However after Web service was successfully generated, saved, verified, and published to organization, when I try to run Web Service Test Operation, the SOAP Request popup window doesn't have my defined parameters displayed.  Instead, it named xml tag as 
       <stringParam>PARAMETER</stringParam>
      <stringParam1>PARAMETER</stringParam1>
I tried to update/recreate web service repeatedly through different routes but still not getting correct parameter names which really drive me crazy.

Can anyone help me out?  Why it happens and how to avoid it?

Thanks.
Yi 

Comments

  • Ethan BeisherEthan Beisher AppWorks Solution Expert EM
    When you generate your web service and select the methods, you can click on the method and name the parameters. If you have already published the web service, you may need to delete it from AppWorks Platform or restart the service container to see the change.
Sign In or Register to comment.