Trying to get OT CS Mobile 21.4 to Co-operate

Options

I have hit the end of my debugging on trying to make CS21.4 work on a CS21.4 Server.

I installed OTAG 21.2 on a Tomcat Box,did all the pre requistes of connecting it to OTDS and it create partitions everything correctly.

I then deployed CS21.4 in that gateway paying attention to what OT said to create a proxy rule

So far good I downloaded it on my IOS phone and when I go and type in my userid and password(otdsadmin works as well) the page flashes' makes me pick a PIN and so on.

The continue was not in a checked state which I have been playing with what it should be

so about 5 minutes after I login in my phone it permanently stays in


For testing purposes there is a single perspective that shows which works fine in smartui I don't have any rules per se.

If I click on say Home or favorites or anything first it will say do you want to work offline I say no because I want to see what is in my CS.


The localhost_access_log registers a rest api to CS which is successful but nothing on the phone

IPADDRESS - - [04/Feb/2022:16:03:13 +0000] "GET /llisapi.dll/api/v2/members/favorites?metadata=&fields=properties%7Bowner_user_id%2Cname%2Cfavorite%2Creserved%2Csize_formatted%2Cmodify_date%2Ctype_name%2Ctype%2Cvolume_id%2Cdescription%2Ccontainer%2Ccreate_user_id%2Cid%2Cparent_id%2Ccontainer_size%2Ccreate_date%2Cmodify_user_id%2Creserved_user_id%2Coriginal_id%2Cmime_type%7D&fields=versions%7Bmime_type%2Cfile_size%2Cversion_id%2Cfile_name%7D.element(0)&expand=properties%7Bowner_user_id%7D&actions=addcategory&actions=addversion&actions=add&actions=default&actions=open&actions=browse&actions=delete&actions=properties&actions=download&actions=rename&actions=reserve&actions=reservedoc&actions=unreserve&actions=unreservedoc&actions=favorite&actions=nonfavorite&actions=location&actions=select&actions=copy&actions=move&actions=initiateworkflow&actions=initiatedocumentworkflow&actions=email&actions=call HTTP/1.1" 200 922

does this mean it is invoking the restapi endpoint on that rewritten URL ?

Comments

  • Appu Nair
    Appu Nair Member
    edited February 4, 2022 #2
    Options

    Well using a Andoid emulator found in google we made it working but iOS is refusing to work BTW I used postman on the above query and the favorites query and the above one did not work but the favorites worked. That got us thinking of using an emulator and finally a person in my team had a android phone and that worked so suffice to say that test all interfaces and devices. If we get it working with iOS I will update.

  • Hi Appu - We found a bug with the CS Mobile for iOS as well. OT development is working on a new release of the CSMobile and they hope to have bugs exterminated in the new release (was due out early April '22 and we are anxiously awaiting the release). Not sure if they are addressing the specific bug that you are experiencing. When we would log into csm with iOS, and open a document passed from another front end....it opened document #1 as expected. When the users clicked on document #2 link from the front end app...csm opened document #1. You may want to try unchecking the "Do Not Proxy OTDS" in your Settings page. That checkbox was also causing unexpected behavior in our environment.

  • Appu Nair
    Options

    @Jeff Piggott Thanks Jeff I dropped the IOS ball as the emulator was enough for me :) I do think I have tried every setting do not proxy blah blah and gave up on my iphone

  • Sadly, iOS is our corporate standard for our company issued phones. I had to chase it up the OT product development chain. :)

  • @geometry dash world I'm not sure whether they are taking care of the particular issue you are having. Document #1 opened as expected when we used our iOS device to log into CSM and access a document that was provided from another front end.