Date and time format incorrect in Documentum Administrator and D2

Hi all,
I have this issue with Documentum Administrator and D2 whereby the dates are not tallying and getting this error... {1st image}

however i manage to overcome this in the past where I edited the dfc.properties and added dfc.date_format = yyyy:MM:dd HH:mm:SS. But i think it affected the date and time format in the D2 when I am trying to create folder / files. It defaults to 2023-01-01 00:00:00. For the time is -8 hours from my time which is SGT.

 Please do let me know if anyone knows how to solve this. Thanks!

Tagged:

Answers

  • The documentum version is 23.2. Upgraded from 16.4.

    Please help if you know how to solve this.

    Much appreciated. Thanks. :)

  • HERVE Loic
    edited December 7, 2023 #3

    You should use: dfc.date_format=dd/mm/yyyy hh:mi:ss

    You have the month instead of minutes in your format, which is an unrecognized format and cause the time to be set to 00:00:00

    (wrong format)

  • Hi Herve,

    Thank you for that. However Documentum Administrator only seems to be loading / working when I put it in that format. Also the date seems to be wrong meaning its defaulting to 2023-01-01. For documents that I upload the time is showing but it is just 8 hours backwards of my timezone.

  • Sorry, my answer was wrong, I edited it.

  • Not sure if this is related but did you set -Djava.locale.providers=COMPAT,SPI ?

  • Hi Hicham,

    Yes I did, in environment variables and in tomcat Java options as well.

  • Hi all,
    I found the solve for this.
    If you are migrating over from an old environment make sure to check the ODBC driver configuration as in if your old environment uses driver Native Client, then when you are migrating over to the new environment or upgrading to a newer version of documentum. Make sure the ODBC driver is configured as ODBC driver 17 for SQL Server. Also make sure that the SSMS is installed first on the machine.

    Usually it doesn't give the option to choose the specific driver at the configuration stage of the Repo, but you can change it later in the server.ini file. Make sure the naming convention is correct.

  • Good to know, thanks.