Version of OpenJDK Java for TeamSite 23.4.x on Linux RHEL 8.6.

Options

Hi,

We are getting ready to install TeamSite 23.4.x on a new Linux RHEL 8.6 server. I looked in the Release Notes for TS23.4, and it says Linux RHEL8.6 is supported with OpenJDK11.0.19.

So I went to adoptium, but I don’t see any OpenJDK11.0.19 there!!! Instead I downloaded the closest version to that for Linux RHEL that I could find, 11.0.23 (OpenJDK11U-jdk_x64_linux_hotspot_11.0.2_9.tar.gz).

The checksums matched, and I unzipped and set environment variables, but when I went to run it I received the following error:

java -version
/usr/lib/jvm/jdk-11.0.23+9/bin/java: cannot execute binary file: Exec format error

I believe that indicates the wrong Java for the platform. So which is the right one???

As well as providing the correct answer here, OpenText needs to correct their documentation so other people do not have to go down the wrong path.

Comments

  • AlwaysProblemsWithOT
    Options

    …update. I finally found it I think, had to go deep into odoptium's archives.

    Found OpenJDK11U-jdk_x64_linux_hotspot_11.0.19_7.tar.gz

    I think this is the one, looks like it works on the server:

    java -version
    openjdk version "11.0.19" 2023-04-18
    OpenJDK Runtime Environment Temurin-11.0.19+7 (build 11.0.19+7)
    OpenJDK 64-Bit Server VM Temurin-11.0.19+7 (build 11.0.19+7, mixed mode)

    So I think I have solved my own problem, well done me! Also hope it helps anyone else in the same boat.

TeamSite Developer Resources

  • Docker Automation

  • LiveSite Content Services (LSCS) REST API

  • Single Page Application (SPA) Modules

  • TeamSite Add-ons

If you are interested in gaining full access to the content, you can register for a My Support account here.
image
OpenText CE Products
TeamSite
APIs