Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
FormsPublisher java.lang.NullPointerException error after upgrade to 6.7.2 SP2
mcockerill
When I open FormsPublisher form that I created in TeamSite 6.7.1, I receive the error below. We recently upgraded to 6.7.2 SP2. If I try to submit the form I get a separate JavaScript error ("Object doesn't support this property or method").
HTTP Status 500 -
--------------------------------------------------------------------------------
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
java.lang.NullPointerException
com.interwoven.formspub.datacapture_005fbuttonframe_jsp._jspService(datacapture_005fbuttonframe_jsp.java:285)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
com.interwoven.ui.base.impl.auth.AuthenticationFilter.doFilter(AuthenticationFilter.java:203)
com.interwoven.ui.base.util.SetRequestEncodingFilter.doFilter(SetRequestEncodingFilter.java:106)
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.
--------------------------------------------------------------------------------
Apache Tomcat/6.0.18
From the servletd_err.log log file:
Oct 27, 2009 1:24:04 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet com.interwoven.formspub.datacapture_005fbuttonframe_jsp threw exception
java.lang.NullPointerException
at com.interwoven.formspub.datacapture_005fbuttonframe_jsp._jspService(datacapture_005fbuttonframe_jsp.java:285)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at com.interwoven.ui.base.impl.auth.AuthenticationFilter.doFilter(AuthenticationFilter.java:203)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at com.interwoven.ui.base.util.SetRequestEncodingFilter.doFilter(SetRequestEncodingFilter.java:106)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
at java.lang.Thread.run(Thread.java:595)
Does anyone have any ideas? Did something change in teh way the datacapture.cfg file needs to be set up? Or perhaps this is a permission problem?
Thanks in advance,
Marc Cockerill
Find more posts tagged with
Comments
Adam Stoller
Does the problem happen for:
mcockerill
Here is some more information:
-Server is running Windows 2003.
-Happens in both IE 7.0 and Firefox 3.5.3
- Seems to be happening to all DCRs for all data types. Have removed custom <script> and still receive the same issue. Seems to be system wide thing, not related to my DCRs.
- The error message appears immediately under the "Edit " box on the top of the form.
Anyone encounter something similar?
Thanks in advance,
-Marc Cockerill
mcockerill
Lets try that again.
Here is some more information:
-Server is running Windows 2003.
-Happens in both IE 7.0 and Firefox 3.5.3
- Seems to be happening to all DCRs for all data types. Have removed custom script and still receive the same issue. Seems to be system wide thing, not related to my DCRs.
- The error message appears immediately under the "Edit (dcr name)" box on the top of the form.
Anyone encounter something similar?
Thanks in advance,
-Marc Cockerill
Adam Stoller
Find or create a workarea somewhere where you can load all the example templates that come with TS, configure templating.cfg appropriately for them, and see if you can replicate the problem with any of those templates.
If you can - contact Support as there would seem to be something wrong with your system and they should be able to work with you in resolving it.
If you cannot - you will have to spend more time debugging your DCTs and DCRs (another thing to check is the usage of VFE and/or TinyMCE in the DCTs - try changing them temporarily to plain textareas and see if the problem persists or goes away)
new_report_4.rptdesign