Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
mod_a2_iw_ts_vpath.so not loading in Teamsite 6.7.1 SP1 Linux env.
System
Hi,
Teamsite 6.7.1 SP1
Red Hat Linux 4.0
Apache/2.0.59
I am trying to setup the preview (customer) webserver, whihc is an Apache (2.0.59) web server. I am facing an issue when i add the below line in the httpd.conf file.
LoadModule a2_iw_ts_vpath_module "/opt/apache/apache/modules/standard/mod_a2_iw_ts_vpath.so"
After adding the above line, and then if i restart Apache webserver i get the following error.
Starting Apache
Syntax error on line 76 of /opt/apache/servers/https-80/conf/httpsd.conf:
Cannot load /opt/apache/apache/modules/standard/mod_a2_iw_ts_vpath.so into server: /opt/apache/apache/modules/standard/mod_a2_iw_ts_vpath.so: cannot open shared object file: No such file or directory
Server start FAILED
Please let me know if anyone has faced this issue and any solutions for this. Thanks!
Find more posts tagged with
Comments
Crsb
what does "ll /opt/apache/apache/modules/standard/mod_a2_iw_ts_vpath.so" return??
you can also try just: modules/mod_a2_iw_ts_vpath.so
Migrateduser
Thanks for the reply !
ls /opt/apache/apache/modules/standard/mod_a2_iw_ts_vpath.so returns me
/opt/apache/apache/modules/standard/mod_a2_iw_ts_vpath.so
So the file exists on the specified folder.
I also tried adding modules/mod_a2_iw_ts_vpath.so, but the issue still exists.
Any other ideas? One more thing i forgot to mention is the OS is 64 bit. Will this makes any difference, since the Teamsite and Apache webserver are 32 bit applications.
Crsb
This might be obvious, but it is worth asking:
are changing the right httpd.conf? and restarting the right apache? sometimes people would install multiple version of apache and not update the right instance...
Migrateduser
Yes, i am changing the right httpd.conf file and starting the correct Apache webserver instance.
kissthedevil
You might want to look out for swiping the
.so
file here. So if the server is looking for a 64bit file it might be getting a 32bit file. I had a similar issue wherein a
.so
file was giving an error. I renamed the original
.so
file and used a 32bit as TS looks for 32bit binaries and not 64bit. Or you can try vice versa.