We installed Teamsite 6.7.2 last week and completed the environment set ups and customisation. Today , we faced connection issue. Teamsite is not starting.
i have pasted below the log file contents. Please help.
iwserver.log
----------------------------------------
bash-3.00# view iwserver.log
"iwserver.log" [Read only] 1974 lines, 93870 characters
iwuiboot: ---------- STOPPING: Wed Nov 18 02:02:32 IST 2009
/opt/Interwoven/TeamSite/iw-webd/bin/iw.webd stop: iwwebd (no pid file) not runn
ing
iwuiboot: ---------- STOPPED: Wed Nov 18 02:02:38 IST 2009
iw.server: ---------- STARTING: Wed Nov 18 03:38:03 IST 2009
iwetcboot: Running iwstart /opt/Interwoven/iw-store in /opt/Interwoven/TeamSite
iwstart: The events log file is /opt/Interwoven/TeamSite/local/logs/iwevents.log
iwstart: WFS device driver path is /dev/iwovwfs
iwstart: ERROR: The kernel driver should have been installed by now.
iwstart: ERROR: Did you reboot after installing TeamSite?
#######################################################
### You MUST reboot the machine after installation ###
### to ensure correct function. ###
#######################################################
ERROR: Failed to start.
iw.server: ---------- STOPPING: Wed Nov 18 03:43:07 IST 2009
Interwoven CSSDK SOAP Server Stopping ...
Interwoven Servlet Engine stopping ...
ERROR: Cannot connect, server is probably not running.
"iwserver.log" [Read only] 1974 lines, 93870 characters
iwuiboot: ---------- STOPPING: Wed Nov 18 02:02:32 IST 2009
/opt/Interwoven/TeamSite/iw-webd/bin/iw.webd stop: iwwebd (no pid file) not running
iwuiboot: ---------- STOPPED: Wed Nov 18 02:02:38 IST 2009
iw.server: ---------- STARTING: Wed Nov 18 03:38:03 IST 2009
iwetcboot: Running iwstart /opt/Interwoven/iw-store in /opt/Interwoven/TeamSite
iwstart: The events log file is /opt/Interwoven/TeamSite/local/logs/iwevents.log
iwstart: WFS device driver path is /dev/iwovwfs
iwstart: ERROR: The kernel driver should have been installed by now.
iwstart: ERROR: Did you reboot after installing TeamSite?
#######################################################
### You MUST reboot the machine after installation ###
### to ensure correct function. ###
#######################################################
ERROR: Failed to start.
iw.server: ---------- STOPPING: Wed Nov 18 03:43:07 IST 2009
Interwoven CSSDK SOAP Server Stopping ...
Interwoven Servlet Engine stopping ...
ERROR: Cannot connect, server is probably not running.
ERROR: Failed to stop Interwoven Servlet Engine. Check /opt/Interwoven/TeamSite/local/logs/iwui/servletd_out.log
Interwoven Proxy Server stopping ...
Interwoven Web Daemon stopping ...
/opt/Interwoven/TeamSite/iw-webd/bin/iw.webd stop: iwwebd (no pid file) not running
iwuiboot: ---------- STOPPED: Wed Nov 18 03:43:14 IST 2009
Interwoven Event Subsystem stopping ...
Unable to establish connection with server:5000013: Unable to establish connection with server
iwmount: Unmounting /iwmnt/default...
umount: warning: /iwmnt/default not in mnttab
umount: /iwmnt/default no such file or directory
iwmount: Failed to umount ...
iwmount: Unmounting /.iwmnt/default...
umount: warning: /.iwmnt/default not in mnttab
umount: /.iwmnt/default no such file or directory
iwmount: Failed to umount ...
iwetcboot: Running iwstop ...
iwstop: already stopped
iw.server: ---------- STOPPED: Wed Nov 18 03:43:17 IST 2009
S16iw.server: ---------- STARTING: Wed Nov 18 04:31:32 IST 2009
iwetcboot: Running iwstart /opt/Interwoven/iw-store in /opt/Interwoven/TeamSite
iwstart: The events log file is /opt/Interwoven/TeamSite/local/logs/iwevents.log
iwstart: WFS device driver path is /dev/iwovwfs
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
iwevents.log
-----------------------
[Fri Nov 20 06:55:12 2009] tsmaster master UnLock /default/main/internet/WORKAREA/shared /templatedata/admin/li
vesite_placeholder_data.xml 0x000010084b05ea416000001b 501 Locked by launching edit.
[Wed Nov 25 03:33:54 2009] iwts master StartUp
[Wed Nov 25 03:45:09 2009] root master Freeze 86400 -
[Wed Nov 25 03:45:10 2009] iwts master ShutDown
[Wed Nov 25 03:48:28 2009] iwts master StartUp
[Wed Nov 25 04:41:32 2009] root master Freeze 86400 -
[Wed Nov 25 04:41:33 2009] iwts master ShutDown
[Wed Nov 25 04:42:11 2009] iwts master StartUp
[Wed Nov 25 04:56:22 2009] root master Freeze 86400 -
[Wed Nov 25 04:56:23 2009] iwts master ShutDown
[Wed Nov 25 04:57:36 2009] iwts master StartUp
[Wed Nov 25 05:23:14 2009] iwts master StartUp
[Wed Nov 25 05:27:57 2009] root master Freeze 86400 -
[Wed Nov 25 05:27:58 2009] iwts master ShutDown
[Wed Nov 25 06:21:51 2009] iwts master StartUp
[Wed Nov 25 06:32:18 2009] root master Freeze 86400 -
[Wed Nov 25 06:32:19 2009] iwts master ShutDown
[Wed Nov 25 06:40:44 2009] iwts master StartUp
[Wed Nov 25 07:22:29 2009] iwts master StartUp
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
eventsubd.log
-----------------------
bash-3.00# view eventsubd.log
"eventsubd.log" [Read only] 433 lines, 28857 characters
iweventsubd: ---------- STOPPING: Wed Nov 18 03:43:14 IST 2009
EVENTSUBD_HOME is set to /opt/Interwoven/TeamSite/eventsubsystem
org.exolab.jms.tools.admin.OnlineConnectionException: Failed to connect: javax.jms.JMSException: Connection refused
at org.exolab.jms.tools.admin.OnlineConnection.(OnlineConnection.java:151)
at org.exolab.jms.tools.admin.AdminMgr.main(AdminMgr.java:655)
Failed to initialize AdminMgr.
Exiting....
iweventsubd: ---------- STOPPED: Wed Nov 18 03:43:16 IST 2009
iweventsubd: ---------- STARTING: Wed Nov 18 04:32:05 IST 2009
EVENTSUBD_HOME is set to /opt/Interwoven/TeamSite/eventsubsystem
OpenJMS 0.7.6.1
The OpenJMS Group. (C) 1999-2004. All rights reserved.
http://openjms.sourceforge.netiweventsubd: ---------- STARTED: Wed Nov 18 04:32:28 IST 2009
04:35:21.873 ERROR [server-2] - Failed to initialise destination cache
org.exolab.jms.persistence.PersistenceException:
java.sql.SQLException: A lock could not be obtained within the time requested
at org.apache.derby.client.am.SQLExceptionFactory.getSQLException(Unknown Source)
at org.apache.derby.client.am.SqlException.getSQLException(Unknown Source)
at org.apache.derby.client.am.PreparedStatement.executeQuery(Unknown Source)
at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:205)
at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:205)
at org.exolab.jms.persistence.Messages.getNonExpiredMessages(Messages.java:545)
at org.exolab.jms.persistence.RDBMSAdapter.getNonExpiredMessages(RDBMSAdapter.java:673)
at org.exolab.jms.messagemgr.MessageLeaseHelper.init(MessageLeaseHelper.java:286)
at org.exolab.jms.messagemgr.MessageLeaseHelper.(MessageLeaseHelper.java:128)
at org.exolab.jms.messagemgr.DestinationCache.init(DestinationCache.java:162)
at org.exolab.jms.messagemgr.TopicDestinationCache.(TopicDestinationCache.java:115)
at org.exolab.jms.messagemgr.DestinationManager.createDestinationCache(DestinationManager.java:219)
at org.exolab.jms.messagemgr.DestinationManager.createDestinationCache(DestinationManager.java:196)
at org.exolab.jms.messagemgr.TopicConsumerEndpoint.(TopicConsumerEndpoint.java:151)
at org.exolab.jms.messagemgr.DurableConsumerEndpoint.(DurableConsumerEndpoint.java:113)
at org.exolab.jms.messagemgr.ConsumerManager.createDurableConsumerEndpoint(ConsumerManager.java:424)
at org.exolab.jms.server.JmsServerSession.createSubscriber(JmsServerSession.java:771)
at org.exolab.jms.server.mipc.IpcJmsSessionConnection.createSubscriber(IpcJmsSessionConnection.java:588)
at org.exolab.jms.server.mipc.IpcJmsSessionConnection.notify(IpcJmsSessionConnection.java:165)
at org.exolab.jms.server.mipc.IpcJmsReceiver.notify(IpcJmsReceiver.java:100)
at org.exolab.jms.server.mipc.IpcServerChannel.run(IpcServerChannel.java:161)
Caused by: org.apache.derby.client.am.SqlException: A lock could not be obtained within the time requested
at org.apache.derby.client.am.Statement.completeSqlca(Unknown Source)
at org.apache.derby.client.am.Statement.completeOpenQuery(Unknown Source)
at org.apache.derby.client.net.NetStatementReply.parseOpenQueryFailure(Unknown Source)
at org.apache.derby.client.net.NetStatementReply.parseOPNQRYreply(Unknown Source)
at org.apache.derby.client.net.NetStatementReply.readOpenQuery(Unknown Source)
"eventsubd.log" [Read only] line 1 of 433 --0%--
at org.exolab.jms.server.JmsServer.init(JmsServer.java:185)
at org.exolab.jms.server.JmsServer.main(JmsServer.java:229)
iweventsubd: ---------- STARTING: Wed Nov 25 07:22:31 IST 2009
EVENTSUBD_HOME is set to /opt/Interwoven/TeamSite/eventsubsystem
OpenJMS 0.7.6.1
The OpenJMS Group. (C) 1999-2004. All rights reserved.
http://openjms.sourceforge.netError connecting to server, will retry 5 more times with 10 sec wait
Error connecting to server, will retry 4 more times with 10 sec wait
Error connecting to server, will retry 3 more times with 10 sec wait
Error connecting to server, will retry 2 more times with 10 sec wait
Error connecting to server, will retry 1 more times with 10 sec wait
Error connecting to server, will retry 0 more times with 10 sec wait
org.exolab.jms.server.ServerException: org.exolab.jms.persistence.PersistenceException: java.lang.NullPointerException
at org.exolab.jms.persistence.RDBMSAdapter.getSchemaVersion(RDBMSAdapter.java:875)
at org.exolab.jms.persistence.RDBMSAdapter.(RDBMSAdapter.java:182)
at org.exolab.jms.persistence.DatabaseService.createRdbmsAdapter(DatabaseService.java:236)
at org.exolab.jms.persistence.DatabaseService.(DatabaseService.java:163)
at org.exolab.jms.persistence.DatabaseService.instance(DatabaseService.java:115)
at org.exolab.jms.server.JmsServer.registerServices(JmsServer.java:274)
at org.exolab.jms.server.JmsServer.init(JmsServer.java:185)
at org.exolab.jms.server.JmsServer.main(JmsServer.java:229)
-------------------------------------------------------------------------
servletd_out.log
----------------------
bash-3.00# view /opt/Interwoven/TeamSite/local/logs/iwui/servletd_out.log
"/opt/Interwoven/TeamSite/local/logs/iwui/servletd_out.log" [Read only] 56849 lines, 3718926 characters (178173 null)
Using CATALINA_BASE: /opt/Interwoven/TeamSite/servletd
Using CATALINA_HOME: /opt/Interwoven/TeamSite/servletd
Using CATALINA_TMPDIR: /opt/Interwoven/TeamSite/servletd/temp
Using JAVA_HOME: /opt/Interwoven/TeamSite/tools/java
Using CLASSPATH: :/opt/Interwoven/TeamSite/tools/java/lib/tools.jar:/opt/Interwoven/TeamSite/servletd/bin/bootstrap.jar:/opt/I
nterwoven/TeamSite/servletd/bin/commons-logging-api.jar
Nov 18, 2009 2:02:33 AM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:520)
at java.net.Socket.connect(Socket.java:470)
at java.net.Socket.(Socket.java:367)
at java.net.Socket.(Socket.java:180)
at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:395)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:344)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:435)
cat: cannot open /opt/Interwoven/TeamSite/local/logs/iwui/servletd.pid
Killing:
cat: cannot open /opt/Interwoven/TeamSite/local/logs/iwui/servletd.pid
/opt/Interwoven/TeamSite/servletd/bin/servletd: usage: kill [ [ -sig ] id ... | -l ]
Using CATALINA_BASE: /opt/Interwoven/TeamSite/servletd
Using CATALINA_HOME: /opt/Interwoven/TeamSite/servletd
Using CATALINA_TMPDIR: /opt/Interwoven/TeamSite/servletd/temp
Using JAVA_HOME: /opt/Interwoven/TeamSite/tools/java
Using CLASSPATH: :/opt/Interwoven/TeamSite/tools/java/lib/tools.jar:/opt/Interwoven/TeamSite/servletd/bin/bootstrap.jar:/opt/I
nterwoven/TeamSite/servletd/bin/commons-logging-api.jar
Nov 18, 2009 3:43:09 AM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:520)
"/opt/Interwoven/TeamSite/local/logs/iwui/servletd_out.log" [Read only] 56849 lines, 3718926 characters (178173 null)
Nov 25, 2009 6:32:10 AM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:520)
at java.net.Socket.connect(Socket.java:470)
at java.net.Socket.(Socket.java:367)
at java.net.Socket.(Socket.java:180)
at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:395)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:344)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:435)
Killing: 27393
/opt/Interwoven/TeamSite/servletd/bin/servletd: kill: no such process
Thanks in advance
Ravi