Hi,I have this deployment failure not at all times but rarely and the cause is it is not able to get the file data.Please find the errors seen in the OD receiver logLIB: (3) id=m11237 2011-02-03 21:55:58 -- Processing file(/usr2/wlp_apps1032/iw-runtime/index/website/_2.cfs)LIB: (3) id=m11237 2011-02-03 21:55:58 Cleaning: /usr2/wlp_apps1032/iw-runtime/index/website/_2.cfs.iwtmpLIB: (3) id=m11237 2011-02-03 21:55:58 file created[/usr2/wlp_apps1032/iw-runtime/index/website/_2.cfs.iwtmp] LIB: 2011-02-03 21:56:03 00028LIB: 2011-02-03 21:56:03 ERROR: Failed cleaning up(/usr2/wlp_apps1032/iw-runtime/index/website/_2.cfs.iwtmp)LIB 00017: 2011-02-03 21:56:03 ERROR: Could not get file data(./_2.cfs) from socket.Has anybody faced the similar error.Please can you share/suggest ideas for avoiding this sort of situations.
Hi Ghoti,OpenDeploy version is 7.1Both source and target systems are Solaris.It is a fan-out deployment and non-transactional deployment.Yeah this is a filelist- based deployment.Do you have multiple deployments to the same target server(s) going on at the same time?NoI have multiple deployments to different target servers going on same time.I am trying to deploy the same file through two different, but concurrent, deployments to the same directory location on the different receiver(s).
Yes this deployment process is run as root.We are deploying the same files to 10 different targets and this deployment happens to all targets all time but rarely fails and the error is the same.
Take a look at this old KB Article, it may help.Note that transactional Deployment requires three times more free disk space than thecombined size of your Deployment Collection. That is because at certain phase threeinstances of each file exist simultaneously (.iwnew, .iwold and .iwtmp)