Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
TeamSite 7.1 UI won't come up after running build.bat in livesite_customer_src
kgilmore
After updating our custom code in livesite_customer_src and running build.bat, the TeamSite UI does not come up -- Tomcat gives a 404 error.
No errors were reported to the console during the running of build.bat.
Tried iwreset -ui, iwreset -a, and a full reboot, with same results.
We have installed the same custom code on our development TS server (same specs) and did not have this issue.
Environment:
Windows 2003 Server R2 Standard Edition SP1
TeamSite 7.1
OpenDeploy 7.1
LSCS Authoring
LSCS Preview
Here is an excerpt from our servletd_out.log file:
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Jun 30, 2010 3:37:22 PM org.apache.catalina.core.ApplicationContext log
INFO: Set web app root system property: 'iw-preview' = [D:\Interwoven\TeamSite\httpd\webapps\iw-preview\]
Jun 30, 2010 3:37:22 PM org.apache.catalina.core.ApplicationContext log
INFO: Initializing Log4J from [D:\Interwoven\TeamSite\httpd\webapps\iw-preview\WEB-INF\classes\log4j.xml]
Jun 30, 2010 3:37:23 PM org.apache.catalina.core.ApplicationContext log
INFO: Initializing Spring root WebApplicationContext
15:37:23,736 ERROR [ContextLoader] Context initialization failed
org.jasypt.exceptions.EncryptionOperationNotPossibleException
at org.jasypt.encryption.pbe.StandardPBEByteEncryptor.decrypt(StandardPBEByteEncryptor.java:801)
at org.jasypt.encryption.pbe.StandardPBEStringEncryptor.decrypt(StandardPBEStringEncryptor.java:639)
at org.jasypt.properties.PropertyValueEncryptionUtils.decrypt(PropertyValueEncryptionUtils.java:72)
at org.jasypt.spring.properties.EncryptablePropertyPlaceholderConfigurer.convertPropertyValue(EncryptablePropertyPlaceholderConfigurer.java:107)
at org.springframework.beans.factory.config.PropertyResourceConfigurer.convertProperties(PropertyResourceConfigurer.java:95)
at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:72)
...
Any idea what could be going on here?
Find more posts tagged with
Comments
kgilmore
Never mind. Had some host-specific properties files from our other TeamSite server ending up in livesite_customer_src.
Replaced those with the correct files, re-ran build.bat, and everything's fine.