Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
DataDeploy Error
rodigz
DBD: Running deployment [db-to-xml]
DBD: Connect attempt Failed:Reason:null
DBD: ERROR:
java.lang.NullPointerException
at java.util.Hashtable.put(Hashtable.java:394)
at com.interwoven.dd100.dd.JdbcCheckup.MakeConnection(JdbcCheckup.java:424)
at com.interwoven.dd100.dd.JdbcCheckup.TryConnect(JdbcCheckup.java:586)
at com.interwoven.dd100.dd.TDbTupleProducer.(TDbTupleProducer.java:58)
at com.interwoven.dd100.dd.TAgentClient.DoDatabaseSource(TAgentClient.java:449)
at com.interwoven.dd100.dd.TAgentClient.DoOneDeployment(TAgentClient.java:291)
at com.interwoven.dd100.dd.TAgentClient.Go(TAgentClient.java:178)
at com.interwoven.dd100.dd.IWDataDeploy.Go(IWDataDeploy.java:598)
at com.interwoven.dd100.dd.TDASThread.ProcessItem(TDASThread.java:203)
at com.interwoven.dd100.dd.TDASThread.run(TDASThread.java:128)
Find more posts tagged with
Comments
curiousmaverick
Share both the logs.
mart2001
If you are using Opendeploy 7.1 (Datadeploy 7.1), then you will need to get the updated jdbc driver from Oracle ojdbc6.jar instead of the ojdbc14.jar as version 7.1 uses jdk1.6 instead of jdk1.5 and below. You'll also need to encrypt the password database.xml file in od-home/etc.
swatis
i have encrypted the password and i getting the same error log. DB is sql server 2005. Encoded passwords works fine but encrypted doesn't work for me. I am using teamsite 7.1. Any pointer?
i have attached the ddconfig, deployment.xml. If i give username and password in database node of ddconfig.xml and in database.xml then in the log i get the error Login failed for user 'iwdbadmin'. Maybe the password in the database.xml is overwritten by the one in ddconfig.xml and doesnt get decrypted. Whereas if i encode the password and give username and password in the database section of ddconfig.xml along with database.xml it works fine and data gets into the db. As of now when i have removed the username and password from the database section of ddconfig.xml i get null pointer exception.
I have set strict authentication to yes to test the encrypting functionality.
Rick Poulin
First, you can't mix properties from both database.xml AND your deployment config. Either use <database name="microsoft-db"> OR specify ALL properties of the connection in your deployment config. You're currently getting an NPE because you're somewhere in the middle.
You said it works fine if you use all props in the dd config, and you get a login failure when you use database.xml properly. My guess is that you forgot the password-encoded="yes" attribute in database.xml.
Ref: DD Admin guide v7.1, p. 179
swatis
I could resolve the issue. The problem was in ddconfig.xml i was supposed to give only three attributes use="microsoft-db", enforce-ri, delete-tracker and nothing else in database node.