This seems to be a fix for other IIS related authentication issues as well.We had to re-init our TS_IMP-user and IIS was only showing 401.2 errors after that. Simply deleting and recreating the iw-application solved the issue.