Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Data deploy Error : Unable to determine operation mode
maheshyogi
I could not able to deploy content to data base however I could able able to deploy files to server.
Open deploy UI screen is giving
Unknown Server Error
An unknown error has occurred on the server.
Odbase.log:
ERROR:XXXXXXXXXXXXXXXXXXXXXX
ERROR:ERROR: Unable to determine operation mode
Database Deployment error state: false
iwddexec: : cannot execute
eventReporting.log
ERROR - Error loading JNDI context JndiContext-11.
INFO - Reason: Failed to connect to JNDI provider
WARN - Skipping JNDI context JndiContext-11 and all its subordinate objects.
Environment : Teamsite : 6.5 Opendeploy : 6.0
Please help me to fix the issues if u have any ideas.
Thank you very much for your help in advance.
Find more posts tagged with
Comments
Adam Stoller
Does your OD license include licensing for DD?
Did you fix your odbase.xml file to include the proper settings for DD?
Rick Poulin
Assuming your OD licenses and od config are in order per Adam's post, the "unable to determine operation mode" error is usually caused by invalid DD deployment configurations, e.g. you're referencing a database by name and it doesn't exist in database.xml, or you haven't specified where to find database.xml in your deployment config, or the config contains incorrect syntax (per the DTD) that confuses the deployment. You should see the cause of the error somewhere above the error you posted in the log.
As for the event reporting JNDI error, it appears that you configured OD event reporting to log to a database, and the connection parameters for that DB are invalid.
The two errors are most likely unrelated.
maheshyogi
Earlier OD and DD working perfectly, we have not changed any configurations. Suddenly we have got this error. Is there any command to validate license?
Rick Poulin
od-home/od.log is the log that would tell you whether you have a license problem. If you want to find out quickly without bothering to look through that file, just restart the service and check the log. If there's a problem, it'll tell you. If everything's good with the license, it'll print the details of your license (where you can check that DD is allowed by your license).
Also check odbase.xml to make sure that the <datadeploy> element (or somesuch) is set to enabled="true".
maheshyogi
There is no problem with the license and also is enabled on odbase.xml.
new_report_1.rptdesign
Bhargav Coca
There is no problem with the license and also is enabled on odbase.xml.
What kind of DD are you running? Why not try a sample deployment with OOTB DD config and see if the tables are created. You are sure nothing is changed from the DB point of view in most cases they when TeamSite is right, its the other party which is to blamed (Do not blindly blame on others most of the time it backfires). If I were you i would start from Basic template with simple DD config file deploying to a dev Database table. If i get that working rest is peace of cake.
Thanks
Rick Poulin
I suggest you post a more complete piece of the od.log file relevant to the "unable to determine operation mode" message, esp. what appears before it, and also post any deployment-specific log that may be generated as well in the log folder.