Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
The Interwoven Web Daemon was unable to contact the Interwoven Servlet Engine
SethHickel
Our users are getting the following when trying to log on. All services are up when we get this error. Any clues?
The Interwoven Web Daemon was unable to contact the Interwoven Servlet Engine. The Interwoven Servlet Engine may be down, or running on an unexpected host or port.
Please contact your system administrator.
Find more posts tagged with
Comments
SethHickel
System was accesible after event subsystem services was stopped
SethHickel
Still looking for root cause though
nipper
Is this repeatable ?
I have seen, during a reboot, the daemons start up in the wrong order and takes in iwreset -a to fix.
what OS/rev of TS ?
Crsb
It is probably not in this case, they might get that error msg if the system was overloaded and not responding quick enough.
SethHickel
Well - I really don't want to bring event subsystem up again to test as this may bring my users down.
Our OCC restarted iis, www and http services to no avail. We discovered eventsubsystem was up. As soon as we stopped that service TeamSite was available again.
This is the first time that I have seen this relationship.
TeamSite 6.7.1.0 - Build 60750
OD 6.11 - Build 64682
Intel box
nipper
You will need to try to restart the ESS. You didn't have any plans this weekend, did you ?
Is the DB accessible ? That *should* not matter, but...
Anything int he ESS logs ?
performance.txt
report_for_excell.rptdesign
SethHickel
OK - ignorant flag - ESS?
AggregationInChart.rptdesign
nipper
event sub system
SethHickel
Ah - duh :-)
OK - we don't have ESS running - have not for some time since we do not have search or index running. The issue occured, I think, because ESS was started. We brought down all services last night for a backup (normal, scheduled, process Autonomy blessed) One service failed to start so we, per protocol, exited without finishing the startup of the services. A developer could not access TeamSite and so went on the server and started services. One of them was ESS.
This is the orders that we stop and start from our batch. We wait two minutes between each call.
#Stop Services
prod.stop.service.1=D:/Interwoven/Teamsite/bin/iwreset -ui stop
prod.stop.service.2=net stop iwutild
prod.stop.service.3=net stop iwserver
prod.stop.service.4=net stop iwodadmin
prod.stop.service.5=net stop iwas
prod.stop.service.6=net stop iwod60
#Start Services
prod.start.service.1=net start iwutild
prod.start.service.2=net start iwserver
prod.start.service.3=D:/Interwoven/Teamsite/bin/iwreset -ui start
prod.start.service.4=net start iwod60
prod.start.service.5=net start iwas
prod.start.service.6=net start iwodadmin
Migrateduser
This happened to me as well. My situation was probably unique as I had placed an incompatible class file in \Interwoven\TeamSite\tools\java\jre\lib\ext.
Do you have anything in your log files that you can post?
Did this start happening out of the blue, or did you just install a patch?
Any windows patches lately?
SethHickel
Discovery: Our nightly backup includes stopping all TeamSite and OpenDeploy services and taking a full backup of iw-store. A developer forgot about the schedule and decided to investigate why he could not log onto the UI. While our backup was running he started services including event subsystem. While I don't know specifically what part of his activities caused this error I am sure that his activities caused the error.
It looks like part of the services were up but not all when he began tinkering.
Thanks all.
NegativePieChart.rptdesign
Migrateduser
Why are you stopping all the services during your backup? Why aren't you just freezing and unfreezing your backing store instead?
SethHickel
Long story ...