Your logs didn't get attached.Also mentioned the emvironment details.
I see "[Tue Sep 07 17:30:27 2010] ERROR: iwserver did not come up in 600 seconds[Tue Sep 07 17:30:27 2010] ERROR: Please look at E:\Interwoven\TeamSite\local\logs\iwtrace.log for more information" in server log.Is your TS backing store located on network storage? If so, check if you have any connectivity issues.Check messages from your iwtrace log around the same time stamp
Environment : Windows Server 2003 R2, service pack 22.80 Ghz processor, 8 GB RAM
If this is 64-bit, it won't work. We had the same kinds of errors on 64-bit. Re-imaged to 32-bit and the install was successful.