Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
After TS new Server 6.7.1 Relocation DCT Preview is throwing error
Pummy
Hello,
We have recently moved all the copy of content from one TS to another. The environment is same.
ENV : TS. 6.7.1 SP1 on Solaris 10..
The content store has been copied As-is -As.
When we try to preview the DCT , we get PT error. The same copy of the file*(tpl,dcr,datacapture.cfg) doesnt work !
The Preview of Images, and other html works as normal in same WA, just ensures that web preview is fine and apache is running.
The logs debug output as follows:
---------------------------------------------------------
O/P at servletd_out.log
2010-09-23 17:08:39,786 [http-8080-Processor23] WARN com.interwoven.cssdk.transform.impl.PreviewManifest (acc0184 commandID iw.formspub.do_preview) - exception while deleting manifest file //teamsited2/EMEA/main/Intranet/Inside/hub_inside/WORKAREA/main_wa/templatedata/preview/zz_tst_acc0184_1_manifest
com.interwoven.cssdk.common.CSObjectNotFoundException: /EMEA/main/Intranet/Inside/hub_inside/WORKAREA/main_wa/templatedata/preview/zz_tst_acc0184_1_manifest(Object being looked up was not found)
llllllllllllllllllllllllllllllsome exception tracellllllllllllllllllllllllllllll
2010-09-23 16:00:50,550 [http-8080-Processor19] ERROR com.interwoven.ui.formspub.utils.PerlPTCompiler (acc0184 commandID iw.formspub.do_preview) - UtildClient executing command error. Return Code: 6
---------------------------------------------------------
O/P at iwutild_cmdout.log
"my" variable $mst_vfe masks earlier declaration in same scope at (eval 125) line 71.
"my" variable $mst_columntype_vfe masks earlier declaration in same scope at (eval 125) line 72.
"my" variable $mst_Repurpose masks earlier declaration in same scope at (eval 125) line 73.
"my" variable $mst_columntype masks earlier declaration in same scope at (eval 125) line 74.
"my" variable $headline masks earlier declaration in same scope at (eval 348) line 89.
Could not process template: /.iwmnt/EMEA/main/Intranet/Inside/hub_inside/WORKAREA/main_wa/templatedata/components/pageheader.tpl
Try debugging like this: iwpt_compile ... -ocode ****.ipl; ****.ipl
======================================================
I did following Debugging to before posting:
1. Checked iw.cfg for [[iwserver] and it says webserver_uid=iwts, which is fine for preview user.
2. Checked the iwutild.cfg anb configuration matches the current server.
3. Checked the /iw-home/cssdk/cssdk.cfg and all looks fine.
The preview still throws the error.
The only difference in my Store is now all the group for files is set to {iwglobal|} from earlier {iwts}.
When i checked ls -lrt of any WA,branch i see this differnce.
Please suggest how to go about fixing this issue.
Regards,
Praveen
Find more posts tagged with
Comments
Adam Stoller
The issue appears to be one of permissions.
The reference to 'iwglobal' indicates that you are using TeamSite groups - are you sure that all the groups exist on the new server and that you are a member of the appropriate groups, and that group has access throughout the branch at the file system level?
Pummy
Hi Ghoti,
I just checked the /etc/groups on new server and these are the entries...
iwts::45046:
ovosup::45031:
mwsup2::45053:
iwglobal::45047:iwui
dbasup2::45050:
And i also compared with one old server.. and the group file looks as below..
iwts::45046:nobody,iwui
iwglobal::45046:
sasl::45046:
sanappsvc::19034:
dbasup3::45051:
bcksup1::45006:
hpucmdb::19812:
uxsup1::45003:
bcksup2::45007:
sapcons::45011:
ovosup::45031:
mwsup2::45053:
dbasup2::45050:
So.. on comparision.. the iwts on old server has nobody and iwui.
But the iwglobal which is new group set has only iwui association.
Since i am not so good at Solaris Administration , i have to depend on the another team to address this issue.
Could you kindly let me know., what should i be asking those guys to look into...
Many Thanks in Advance,
Regards,
Praveen
tree.PNG
Adam Stoller
Well, generally speaking you should probably have your sysadmin make sure that the definition of the two groups (iwts and iwglobal) are set (on the new server) to look exactly like they do on the old server - though I'm a bit confused as to how someone got three groups on the old server to have the exact same GID (that looks wrong)
You also want to look at the user definitions - both at the /etc/passwd level and within TeamSite - either the IWHOME/conf/roles/*.uid files or the IWHOME/conf/roles/tsusers.xml (I know the former is 6.5 and earlier and the latter is 6.7.2 and later - I cannot remember off-hand which is used for 6.7.1) and figure out what (if any) discrepancies exist there. You also want to look at the composition of any TS Groups being used (IWHOME/conf/tsgroups.xml) to make sure those are the same (or that differences are understandable)
If UIDs changed for common userids - then you either need to do a bunch of iwidmap runs, or you need to fix the UIDs at the OS level to be the same.
If users are not associated with the same TS groups (or local-server groups that are used within the TS backing store) - then you're likely to run into various permissions issues too.