Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Aspx pages
Lax
We have a new branch in TeamSite by the name WWeb. We had only one workarea within this branch and it is wokring fine. Recently we started using Staging and one other workarea. I find that all aspx files are giving an error in Staging and in the new workarea. The error message is below. Any help will be greatly appreciated.
Thanks,
Server Error in '/iw-mount' Application.
--------------------------------------------------------------------------------
Directory 'Y:\default\main\Intranet\WWeb\STAGING\docroot\iw-mount' does not exist. Failed to start monitoring file changes.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Web.HttpException: Directory 'Y:\default\main\Intranet\WWeb\STAGING\docroot\iw-mount' does not exist. Failed to start monitoring file changes.
Source Error:
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Stack Trace:
[HttpException (0x80070002): Directory 'Y:\default\main\Intranet\WWeb\STAGING\docroot\iw-mount' does not exist. Failed to start monitoring file changes.]
System.Web.FileChangesMonitor.FindDirectoryMonitor(String dir, Boolean addIfNotFound, Boolean throwOnError) +527
System.Web.FileChangesMonitor.StartMonitoringPath(String alias, FileChangeEventHandler callback) +477
System.Web.Caching.CacheDependency.Init(Boolean isPublic, Boolean isSensitive, String[] filenamesArg, String[] cachekeysArg, CacheDependency dependency, DateTime utcStart) +1535
System.Web.Caching.CacheDependency..ctor(Boolean isSensitive, String[] filenames, DateTime utcStart) +50
System.Web.Configuration.HttpConfigurationSystem.GetCacheDependencies(Hashtable cachedeps, DateTime utcStart) +144
System.Web.Configuration.HttpConfigurationSystem.ComposeConfig(String reqPath, IHttpMapPath configmap) +697
System.Web.HttpContext.GetCompleteConfigRecord(String reqpath, IHttpMapPath configmap) +434
System.Web.HttpContext.GetCompleteConfig() +49
System.Web.HttpContext.GetConfig(String name) +195
System.Web.CustomErrors.GetSettings(HttpContext context, Boolean canThrow) +20
System.Web.HttpResponse.ReportRuntimeError(Exception e, Boolean canThrow) +39
System.Web.HttpRuntime.FinishRequest(HttpWorkerRequest wr, HttpContext context, Exception e) +486
Find more posts tagged with
Comments
Migrateduser
I think it may be because staging is readonly and it's trying to write some kind of caching or other dynamic file. This thread may have some help:
http://devnet.interwoven.com/forums/cgi-bin/showthreaded.pl?Cat=&Board=INTEGRATIONS_GENERAL&Number=9356&Search=true&Forum=All_Forums&Words=Failed%20to%20start%20monitoring%20file%20changes&Match=Entire%20Phrase&Searchpage=0&Limit=25&Old=allposts&Main=9356
Lax
Thank you. The post did point me in the right direction. I had forgotten to mark the directories as applications in IIS and that was causing the problem. That fixed it.