Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
LSCS queries built on 7.1 fail on 7.2
Binettoid
Hi I have a set of components built on LSCS queries that work reliably on my 7.1 platform. My client recently updated the target platform for this project to TS 7.2 and preliminary deployments seemed to go well, with custom search components based on LSCSQuery working as expected.
We recently did a larger-scale deployment of a beta-ready site and these components are failing. I know my client has been tooling around with the platform - broke the sitemap for example and then created a new site in the same branch for our testing - but I don't know why these components should be failing.
Does anyone know if there have been any changes in the way LSCS works from 7.1 to 7.2? If so, where are these documented? I've tried deleting the project from LSCS and re-submitting but the results are the same. I'm seeing errors like this;
[HTML]
com.moneystuff.LscsQuery com.interwoven.wcm.lscs.LSCSException: No such resource: /lscs/v1/document/path/templatedata/LiveSite/Factsheet/data/refunds.xml/$&project=//DR1WTSD1/default/main/ms&format=json at com.interwoven.wcm.lscs.impl.JSONExtractionUtils.extractError(JSONExtractionUtils.java:175) at com.interwoven.wcm.lscs.impl.Context.fetchURIAsStream(Context.java:262) at com.interwoven.wcm.lscs.impl.JSONExtractionUtils.extractDocumentFacets(JSONExtractionUtils.java:95) at com.interwoven.wcm.lscs.impl.ClientImpl.getDocumentByPath(ClientImpl.java:155) at com.moneystuff.LscsQuery.doGetDocumentByPath(Unknown Source) at com.moneystuff.LscsQuery.getDocumentByPath(Unknown Source) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.interwoven.livesite.common.util.ClassUtils.executeMethod(ClassUtils.java:105) at com.interwoven.livesite.common.pojo.PojoMethodCall.executeMethod(PojoMethodCall.java:400) at com.interwoven.livesite.common.pojo.PojoMethodCall.execute(PojoMethodCall.java:454) at com.interwoven.livesite.external.ExternalCall.execute(ExternalCall.java:142) at com.interwoven.livesite.runtime.model.component.Component.executeExternal(Component.java:413) at com.interwoven.livesite.runtime.model.page.RuntimeComponent.buildComponentTransformData(RuntimeComponent.java:201) at com.interwoven.livesite.runtime.model.page.RuntimeComponent.transform(RuntimeComponent.java:282) at com.interwoven.livesite.model.page.PreviewPage.renderHtmlComponent(PreviewPage.java:365) at com.interwoven.livesite.model.page.PreviewPage.renderPaletteComponentPage(PreviewPage.java:251) at com.interwoven.livesite.iw.servlet.preview.rendering.PagePaletteRenderingManager.render(PagePaletteRenderingManager.java:151) at com.interwoven.livesite.runtime.impl.BaseRequestContext.render(BaseRequestContext.java:240) at com.interwoven.livesite.iw.servlet.preview.PagePaletteFilter.doFilter(PagePaletteFilter.java:71) at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:183) at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:138) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175) at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:182) at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446) at java.lang.Thread.run(Thread.java:619)
getDocumentByPath
[/HTML]
But we can see that "templatedata/LiveSite/Factsheet/data/refunds.xml" /> can be found by querying the debugpanel in LSCS (BUT NOT by entering the resulting REST query directly), resulting in
[HTML]
-
-
[/HTML]
Anyone have any clues? Yes, document IDs match even though the query is failing, no there is no error message simply 0 results.
Find more posts tagged with
Comments
Binettoid
Er... here's an update - I have two installations (7.1 & 7.2)and only after migrating to the new one (7.2) am i seeing this error on the new platform.
It's taken a while to see this but it seems on the new platform the REST query is subtly different and malformed, e.g.
http://servername:8080/lscs/v1/document/path/templatedata/LiveSite/Factsheet/data/rentalchecklist.xml/$&project=//DR1wwsd1/default/main/ms&format=json
Spot the first & - it should be a ?
But WHY is this happening?
My client has been messing around with this (their) platform and I have no idea what they have done, except that this mechanism (list docs, render links, click through) used to work.
Any ideas greatly appreciated.
Sobbing in desperation, Sydney.
Binettoid
Turns out the 7.2 platform had a faulty lscsclient.jar - odd since it used to work fine a month or so ago. Whooda thunk it?