Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Component not displaying in LSDS until "Invalidate runtime cache" is executed
Murugan_P
We've a Header component whose contents are pulled from,
1. A DCR containing a logo, a text caption and some links.
2. Header menus (Navigation) were from sitemap. Using the OTB sitemap java external.
3. An external component along with a controller which implements the login functionality. This login functionality is taken from the OTB login component and the controller we use is also the same except that we do the user authentication against an LDAP server. We use custom user profile.
When we do a fresh deployment using the OTB workflow and access the page containing this header component, all the functionalities were working fine and the page is displayed as expected in LSDS as well as in SitePublisher.
When we try to access the same page again in LSDS after a day or two from deploying it, the header component alone is not displaying properly.
The content from DCR (Point 1) is showing up.
Whereas in SitePublisher the entire header component is showing up correctly. No changes and no deployments were made whatsoever.
The error message we're getting in the tomcat console of LSDS is below,
SystemId unknown; Line #42; Column #80; Unkown error in XPath.
SystemId Unknown; Line #40; Column #61; java.lang.NullPointerException
But when we do a "invalidate runtime cache" for this page in SitePublisher and then try to access this page in LSDS the header component shows up completely and the functionalities are working fine.
This looks quite strange for us and couldn't able to track the root cause for this problem.
Any pointers to this will be really helpful.
Thanks,
Murugan
TS 7.1, LSCS, LSDS, Win 2003
Find more posts tagged with
Comments
There are no comments yet