Dear All,
We are getting a series of errors in eventsubd.log after restarting TeamSite.
iweventsubd: ---------- STOPPED: Friday, November 26, 2010 10:55:41 PM SGT
iweventsubd: ---------- STARTING: Friday, November 26, 2010 10:56:06 PM SGT
EVENTSUBD_HOME is set to /data/Interwoven/TeamSite/eventsubsystem
OpenJMS 0.7.6.1
The OpenJMS Group. (C) 1999-2004. All rights reserved.
http://openjms.sourceforge.net
iweventsubd: ---------- STARTED: Friday, November 26, 2010 10:56:31 PM SGT
22:58:20.017 ERROR [server-2] - Failed to initialise destination cache
org.exolab.jms.persistence.PersistenceException:
java.sql.SQLException: A lock could not be obtained within the time requested
at org.apache.derby.client.am.SQLExceptionFactory.getSQLException(Unknown Source)
at org.apache.derby.client.am.SqlException.getSQLException(Unknown Source)
at org.apache.derby.client.am.PreparedStatement.executeQuery(Unknown Source)
at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:205)
at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:205)
at org.exolab.jms.persistence.Messages.getNonExpiredMessages(Messages.java:545)
at org.exolab.jms.persistence.RDBMSAdapter.getNonExpiredMessages(RDBMSAdapter.java:673)
at org.exolab.jms.messagemgr.MessageLeaseHelper.init(MessageLeaseHelper.java:286)
at org.exolab.jms.messagemgr.MessageLeaseHelper.(MessageLeaseHelper.java:128)
at org.exolab.jms.messagemgr.DestinationCache.init(DestinationCache.java:162)
at org.exolab.jms.messagemgr.TopicDestinationCache.(TopicDestinationCache.java:115)
at org.exolab.jms.messagemgr.DestinationManager.createDestinationCache(DestinationManager.java:219)
at org.exolab.jms.messagemgr.DestinationManager.createDestinationCache(DestinationManager.java:196)
at org.exolab.jms.messagemgr.TopicConsumerEndpoint.(TopicConsumerEndpoint.java:151)
at org.exolab.jms.messagemgr.DurableConsumerEndpoint.(DurableConsumerEndpoint.java:113)
at org.exolab.jms.messagemgr.ConsumerManager.createDurableConsumerEndpoint(ConsumerManager.java:424)
at org.exolab.jms.server.JmsServerSession.createSubscriber(JmsServerSession.java:771)
at org.exolab.jms.server.mipc.IpcJmsSessionConnection.createSubscriber(IpcJmsSessionConnection.java:588)
at org.exolab.jms.server.mipc.IpcJmsSessionConnection.notify(IpcJmsSessionConnection.java:165)
at org.exolab.jms.server.mipc.IpcJmsReceiver.notify(IpcJmsReceiver.java:100)
at org.exolab.jms.server.mipc.IpcServerChannel.run(IpcServerChannel.java:161)
Caused by: org.apache.derby.client.am.SqlException: A lock could not be obtained within the time requested
at org.apache.derby.client.am.Statement.completeSqlca(Unknown Source)
at org.apache.derby.client.am.Statement.completeOpenQuery(Unknown Source)
at org.apache.derby.client.net.NetStatementReply.parseOpenQueryFailure(Unknown Source)
at org.apache.derby.client.net.NetStatementReply.parseOPNQRYreply(Unknown Source)
at org.apache.derby.client.net.NetStatementReply.readOpenQuery(Unknown Source)
at org.apache.derby.client.net.StatementReply.readOpenQuery(Unknown Source)
at org.apache.derby.client.net.NetStatement.readOpenQuery_(Unknown Source)
at org.apache.derby.client.am.Statement.readOpenQuery(Unknown Source)
at org.apache.derby.client.am.PreparedStatement.flowExecute(Unknown Source)
at org.apache.derby.client.am.PreparedStatement.executeQueryX(Unknown Source)
... 19 more
22:58:20.021 ERROR [server-2] - Failed to createDestinationCache
org.exolab.jms.messagemgr.FailedToInitializeException: Failed to initialise destination cache:Failed to retrieve non-
expired messages
at org.exolab.jms.messagemgr.DestinationCache.init(DestinationCache.java:166)
when we attempted killing the iw processes and to restart TeamSite the error is different:
iweventsubd: ---------- STOPPED: Saturday, November 27, 2010 2:44:44 AM SGT
iweventsubd: ---------- STARTING: Saturday, November 27, 2010 2:45:29 AM SGT
EVENTSUBD_HOME is set to /data/Interwoven/TeamSite/eventsubsystem
OpenJMS 0.7.6.1
The OpenJMS Group. (C) 1999-2004. All rights reserved.
http://openjms.sourceforge.net
Error connecting to server, will retry 5 more times with 10 sec wait
Error connecting to server, will retry 4 more times with 10 sec wait
Error connecting to server, will retry 3 more times with 10 sec wait
Error connecting to server, will retry 2 more times with 10 sec wait
Error connecting to server, will retry 1 more times with 10 sec wait
Error connecting to server, will retry 0 more times with 10 sec wait
org.exolab.jms.server.ServerException: org.exolab.jms.persistence.PersistenceException: java.lang.NullPointerExceptio
n
at org.exolab.jms.persistence.RDBMSAdapter.getSchemaVersion(RDBMSAdapter.java:875)
at org.exolab.jms.persistence.RDBMSAdapter.(RDBMSAdapter.java:182)
at org.exolab.jms.persistence.DatabaseService.createRdbmsAdapter(DatabaseService.java:236)
at org.exolab.jms.persistence.DatabaseService.(DatabaseService.java:163)
at org.exolab.jms.persistence.DatabaseService.instance(DatabaseService.java:115)
at org.exolab.jms.server.JmsServer.registerServices(JmsServer.java:274)
at org.exolab.jms.server.JmsServer.init(JmsServer.java:185)
at org.exolab.jms.server.JmsServer.main(JmsServer.java:229)
iweventsubd: ---------- STOPPING: Saturday, November 27, 2010 2:51:54 AM SGT
EVENTSUBD_HOME is set to /data/Interwoven/TeamSite/eventsubsystem
org.exolab.jms.tools.admin.OnlineConnectionException: Failed to connect: javax.jms.JMSException: Connection refused
at org.exolab.jms.tools.admin.OnlineConnection.(OnlineConnection.java:151)
at org.exolab.jms.tools.admin.AdminMgr.main(AdminMgr.java:655)
Failed to initialize AdminMgr.
Exiting....
I can see that in the OpenJMS log path
(iw-home/eventsubsystem/openjmsdb/ ) the log and seg0 directories contain logs of size upto 800 MB.
We are not using DAS in the environment.
Please help to know if you have faced similar issues.
Environment is TS 6.7.2, OD 6.2, OS - Solaris 10.
.