Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
multisource distribution
skapelle
hi all,
i know that opendeploy 5.6 can handle more than one deployment definitions within one and the same deployment configuration file.
it works like this:
<deployment transactional="no">
<execDeploymentTask useDefinition="def1" />
<execDeploymentTask useDefinition="def2" />
</deployment>
but this doesn't work if the targetFilesystem is the same for both definitions. the error message looks like this:
***ERROR - Starting deployment.
Reason from server: DEPLOY_CONFIG_FILE
Details : Failed converting config file d:\od-home\OPENDE~1\conf\multisource.xml.
Error : CONFIG_FILE.
Details: Duplicated destination area is not allowed: 'd:/od-home/testarea/dest'
any ideas?
THANKS
Find more posts tagged with
Comments
Adam Stoller
If the target area path is the same for both definitions - the error message is correct because the behavior is undefined if each of the definitions should happen to try to deploy the same file to the same destination - or (and often more the case) what should happen if each definition has doDelete enabled.
HOWEVER - if the targets are not identical for both definitions and you are still getting this error - are you deploying to more than one node? If so - then this is a bug (I don't remember the ID) that was fixed in 5.6 SP1.
--fish
Strolling Prime Minister of no fixed address
skapelle
thanks,
problem solved -> SP1
but i have still a problem:
i want two different sources to deploy to one and the same target directory. important is that "doDelete" is enabled, because content in both sources is updated frequently. the problem is that both "doDeletes" interfere with each other and the result is a empty target directory. targetFilters would help but not in my case, because the filestructure of the two sources changes frequently.
is there a known solution?
THANKS
Adam Stoller
The only known solution (as far as I know) is to fix your directory structure and any applications that depend on that directory structure, so that this problem doesn't exist.
Well, okay, there is another possible solution, but it will probably take a bit of work to implement/test/debug...
1) Create a new [temporary] target area on the Base Server
2) Deploy both 'source' areas to this [temporary] target area *without* doDeletes enabled
3) as a nextDeployment - deploy from the [temporary] target area to the actual [remote] target area - with doDeletes enabled
4) Remove the [temporary] workarea
The tricky part of this is handling concurrency- if you have more than one of these deployments running at the same time - do you utilize the same temporary target area or different temporary target areas? In the latter case, how do you define and use this specific temporary target area in both the initial and next deployments? etc.
--fish
Strolling Prime Minister of no fixed address