Dear People,Deployments failed. Error: Failed creating socketOD Receiver 62 Service was not running. The system was not shut down/restarted. Restarted the Services and everything's back to normal... but I don't want OD Receiver to do this to us again and again..I would like to know the reason why OD Receiver 62 Service goes down. Would be a great help for usAny solution will be of great help too...many thanksking silvestre
The service will get down due to the following reasons1. Hanged jobs(too many)2. Too much load(No of deployments)3. Memory space(log files and free space)4. License5. Files Corrupted
Hello Jagadeesh,Many thanks for this info. All eyes now points to 1, 2 and 3.A file with the following name was created at the time the OD Receiver 62 Services stopped - hs_err_pid9976.log inside OpenDeploy folder. The file contained the following error..# An unexpected error has been detected by HotSpot Virtual Machine:## EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7c84cde2, pid=9976, tid=7520## Java VM: Java HotSpot(TM) Server VM (1.4.2_16-b05 mixed mode)# Problematic frame:# C [ntdll.dll+0x4cde2]#Any pointers on this?thanksking silvestre
Its Java/JRE issue. Can you please clarify the below questions1. Is there any frequence on getting this error?2. Is the first time are you getting this error?3. Is OD running by root?4. Your environment details?
1. on first server it happened within a span of 5 days and on the second, in a span a 15 days.2. first time it happened 6 months back on the first server3. Windows 2003, OD Receiver 6.2, on VMware Virtual Platform, Java 6 SE editionthanks,king silv
My suggestion here1. Check the OD compatibility with Java version?2. Is OD running by root?3. Check the ntdll.dll file in Windows and verify the file does not have any issue?4. Is Windows 2003 server has stable patch ?5. Check is there any files are corrupted or permission issue or deadlock issue on usage(OD Service Core files) 6. Is OD properly got installed without any issue?Please raise a support case for this.
1. Java 1.6 is installed and is not compatible with OD Receiver we are using. But command prompt results shows C:\>java -showversionjava version "1.3.1_01"Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_01)Java HotSpot(TM) Client VM (build 1.3.1_01, mixed mode)What does this mean? Java version shows 1.6 in Program files as well as in Java Interface..why this difference?2. OD is running by root (I believe by root you meant Admin..right?)3. found two such files... now how and what to check ?4. W2003 EE SP 2. 5 & 6. no problems with that..thanks for your continued support
Default JDK version for OD is 1.4.2_16. You have to check the applications which are all using Java 1.6 you have to check with support Team on this, will it work if another higher version avail in Teamsite System.
The issue is with JDK version. Autonomy support also confirmed it. Now we have to set the environment variable for OD to use JDK 1.4.2_16.Variable Name - JAVA_HOMEVariable Path - path to Java 1.4.2_16Please do let me know if I am missing something heremany thanks Jagadeesh
You have to set JAVA_HOME point to 1.4.2_16 but at the same time please do analysis of what are the applications running in the system, have dependency with higher version(Java 1.6) other than TS. It will sort out some other application issue arise in future on Java compatibility.Always welcome
There are other programs dependent on other versions of Java. So setting JAVA_HOME as mentioned above is not a good idea I guess.Any other way to set Java 1.4 for OD without affecting other programs?many many thanks in advance
Are you on Windows or Unix?If on Unix - you should be able to set the JAVA_HOME variable within the OpenDeploy startup script, so that it would only affect OpenDeploy.Not sure about Windows, though I imagine there's a way to do it there too (perhaps within the registry associated with OpenDeploy?)
There are other programs dependent on other versions of Java. So setting JAVA_HOME as mentioned above is not a good idea I guess.