Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Teamsite preview is not working on 7.3.2 / RHEL6.3
RaviV08
Team,
After installing 7.3.2, i have created a new html file called welcome.html. When i try to preview the welcome.html, i am observing 404 errors. I don't see any error in the logs. I am not sure what am i missing here.
---------------------------------------
HTTP Status 404 - /iw/cci/meta/injection/iw-mount/default/main/welcome-page/WORKAREA/welcome/Welcome.html
type Status report
message /iw/cci/meta/injection/iw-mount/default/main/welcome-page/WORKAREA/welcome/Welcome.html
description The requested resource (/iw/cci/meta/injection/iw-mount/default/main/welcome-page/WORKAREA/welcome/Welcome.html) is not available.
JBossWeb/2.0.1.GA
Thanks,
Ravi
Find more posts tagged with
Comments
Adam Stoller
To ask the obvious (to me) questions - do you have a "customer web server" running on your TeamSite server? Is it configured to listen on port 81 (default) or some other port for which you've configured TeamSite to connect to (customer_webserver_port setting in /etc/iw.cfg)?
RaviV08
Thanks for your reply. It helped me in poking around content webserver.
At first, i have no clue what content webserver is.
You are right, my content webserver is not up and running. I have restarted my apache web server. It is running on port 81. I have restarted my system as well to make sure all services are restarted.
But preview URL is still broken.
404 ERROR -
http://localhost:8080/iw/cci/meta/injection/iw-mount/default/main/welcome-page/WORKAREA/welcome/Welcome.html
But if i replace above URL prefix,
http://localhost:8080/iw/cci/meta/injection
with
http://localhost:81/
(content webserver). My content webserver is servicing HTML pages succesfully w/o any errors.
So there are two possibilities, either Preview URLs are generated incorrectly because of some misconfiguration or teamsite servlet (/iw/cci/meta/injection) is not initialized or failed to make a request to content web server.
Again, i don't see any errors in the log. Can you let me kwow what else i need to do here ?
sheikh1
check your iw.cfg file for correct regex to evaluate the proxy url. You need to have an entry in your iw.cfg file for ex:
[php][iwproxy_preconnect_remap]
_regex=^/iw-mount/default/main/pilot/WORKAREA/WebSite/(.*)$=
http://localhost:8001/pilotcontext/$1
[/php]
where pilotcontext above is the context file(pilotcontext.xml) in your content webserver(ex. webserver-home/conf/Catalina/localhost/pilotcontext.xml) or you can also add a context entry in your webserver context.xml file
RaviV08
Thanks. But after reading more about iwproxy, it seems i have to configure iwproxy in my browser. This is mentioned in iw.cfg file.
Anyway, my issue is resolved. I did not make any changes to iw.cfg file. Earlier i was accessing teamsite on port 8080 i.e.,
http://localhost:8080/iw-cc
. Then, preview was not working for some reason.
But if i changed the URL to
http://localhost/iw-cc
then everything is working as expected.
Thanks everyone for your help !