Hi All,
We are using multi-tier deployment and the log permisson for the LSCS servers Opendeploy logs were changed to 002.
We are deploying from Base ==> Staging ==> 4 LSCS and 4 LSDS servers.
But some times, the log permission for the OpenDeploy Logs(only LSCS deployment logs) were changed to 002.
It happens randomly and we are not able to figureout the root cause.
2015-11-02 16:14:16.326 GMT+0800 serverLog [ReThread-0] - ENG: ***ERROR - Check the filepath. Filepath might have exceeded maximum path length /app/teamsite/iw-home/OpenDeployNG/log/lscs/rcv.teamsite-areadiff-relay.LSCSRuntimeRelay.Staging_server.to.LSCS_SERVER_1.log2015-11-02 16:14:16.326 GMT+0800 serverLog [ReThread-0] - ENG: ***ERROR - Exception accessing /app/teamsite/iw-home/OpenDeployNG/log/lscs/rcv.teamsite-areadiff-relay.LSCSRuntimeRelay.Staging_server.to.LSCS_SERVER_1.log/app/teamsite/iw-home/OpenDeployNG/log/lscs/rcv.teamsite-areadiff-relay.LSCSRuntimeRelay.Staging_server.to.LSCS_SERVER_1.log (Permission denied)
Our OD is running as non-root and OD version of 7.3.1.
Could any one help on this?
Is OpenDeploy running as 'root' on all servers?
Check 'root's (or whatever account is being used's) umask. It is possible that someone set the default umask [for root or whomever] differently so that when a new log file is created it gets the different permissions.
Hi Ghoti,
Thanks for the reply.
The Opendeploy(Staging and LSCS) is running in owner_ID but TeamSite Base is running in root.
Did you check the umask value for "owner_ID" on [all] the receivers?
0022 is the permission for the all the folders.
I didn't ask you about the permission on the folders - I asked you about the umask of the account.
The easiest way to determine that is to login as that account, or login as root and do a sudo su - account and then type umask and see what comes back.
Thanks all for the valuable replies. The issue is fixed.
The issue is due to the log file which got apppended in the same file name and this make the log to change the permission.