If you use Tomcat and don't host any other apps on that Tomcat instance, you can just stop that Tomcat instance. If you use Websphere or Weblogic, go to the admin console and you can stop the LSCS instance.
So does it mean that changing these property values on runtime doesn't have any effect?Also, if I stop that tomcat instance, the rules will still be executed and pages will throw an error. It needs to be disabled at the root.
AFAIK, you can't just "turn off" LSCS functionality from your pages. The controllers and externals don't care about the lscs.enabled property. Once those are executed by a page, they'll be looking for your LSCS instance. The only way to turn if off is to write wrapper classes around the default ones that look at that property.(also AFAIK, that property is only used by the deployment process. The runtime side only looks at the connection properties, and it will connect as soon as any external/controller attempts to do so)