Other relevant configurations are intact; say,(1) DATADEPLOY=true in OD.lic file(2) Datadeploy is set and uncomment in the odbase.xml file
Restarted OD service; no luck. Only error logged is "Failed to start Data Deploy". Do you think this error might be due to (1) Data Deploy configuration [odbase.xml and OD.lic]; (2) incorrect formation of datadeploy configuration in /od-home/conf/Or, any other possible reason?
...#Thu Feb 19 09:51:56 PST 2009[...]DATADEPLOY=true[...]--Permanent License --License Information[...] Platform : SunOS O/S version : null DataDeploy : true...
...2012-10-04 ... odLog [OpenDeploy Main] - LIB: (2) Bound to interface(rds09470cms21) port (57100)2012-10-04 ... odLog [DDThread] - DD Home : /iw-home/OpenDeployNGOpenDeploy server and its RMI registry started.2012-10-05 ... odLog [...] - ERROR: recv failure, err=131 [Unknown socket error]2012-10-05 ... odLog [...] - IWDeploySock::ReadLineWithLength ERROR: Failed to read length of data buffer from socket.2012-10-05 ... odLog [...] - IWDeploySock::ReadLine ERROR: Failed to read (-1) bytes of data from socket.2012-10-05 ... odLog [...] - ERROR: send failure, err=32 [Unknown socket error]2012-10-05 ... odLog [...] - IWDeploySock::WriteLongLine ERROR: Sending length of data buffer to remote.2012-10-05 ... odLog [...] - IWDeploySock::ReadLongLine ERROR: No response data from remote.2012-10-05 ... odLog [...] - ERROR: send failure, err=32 [Unknown socket error]...
I have got another query;The DB table structure has got a column of datatype 'varbinary' that allows-null; however, in my DataDeploy configuration I have excluded that column, as DataDeploy does not support varbinary data-type in SQL Server database.Does DataDeploy validate all columns in a table structure or only the ones captured in ? The question arises, as I am clueless whether logically a varbinary data-type column fails DataDeploy to start.