Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
TeamSite Templating Failure
AmyRush
We have experienced a "failure" of Teamsite templating from the UI. With no known system changes, today we cannot edit DCR's, Preview or Generate from the UI. Teamsite templates can be generated from the CLT, so my focus turns to the UI interaction with the templating functions.
Has anyone had, or known of anything similar?
We are 5.5.2 on Windows
Find more posts tagged with
Comments
Migrateduser
Are you using Visual Format?
Did you already install the latest Service Pack?
Paulo Gouveia
Royal Caribbean and Celebrity Cruises
Information Tecnology
AmyRush
Yes, we are using the Visual Format Editor. We've got the VFE Patch on, but not the new TS service pack (sp2)
AmyRush
We found the issue with templating. The exact way that this happened is still up for debate. However, the problem was that there were some invisible (junk) characters at the beginning of templating.cfg. There is speculation that copying and pasting within wordpad caused these junk characters to be placed there and invisible.
Melissa Hensley
I want to sincerely thank you for following up and placing a final note explaining what the resolution for your problem was; it saved me a lot of frustration as we had the same issue today. I suspected templating.cfg early on but was unable to locate any problems using Textpad. Because of your posting, I installed a different editor that I've used frequently in the paste to detect similar issues. Sure enough, there were junk characters and removing them resolved the problems.
THANK YOU!!
catalina.2012-02-23.txt
streamstudio.txt
Magnulf
They are not exactly "junk" characters. These characters are the (Unicode) BOM-marking (Byte Order Mark) that defines what kind of encoding the file was saved with. (e.g. UTF-8 or similar).
However, TeamSite and MOST of the XMLParsers TeamSite use does not support BOM-marking and will crash when these characters are found.
Notepad and Wordpad automatically detect the existing encoding of a file, and saves the encoding type as BOM in the very beginning of the file.
This is actually smart, as the editor won't have to autodetect the encoding in the future. However, as you've experienced, this may lead to unfortunate and strange errors as not all Editors and Parsers understands this.
Another strange behaviour that will occur is when you save templating.cfg with BOM, and try to Create a new DCR e.g. New Content Record, it will understand the contents of templating.cfg, and parse, it but when you actually selects the category and template type you want, it will report an error that says something like Could not find template type.... This leads me to believe that TeamSite uses different XMLParsers for different tasks... but this is pure speculation and might be something IWOV could clarify.
(( Best regards
c:\ Magnulf Pilskog
(( Systemdeveloper
Output.docx
Migrateduser
we faced similar problem. But we could create new dcrs with out a problem. The problem only happened with edi/preview/generate in templating. Everything worked fine after removing the BOM in the begining. Still trying to figure out how the BOM character got in there.
TS 5.52 on Win2000
-koti
TechAspect
Edited by brain_wave on 06/04/04 02:07 PM (server time).
Migrateduser
Finally I figured how the special character is introduced. I was using UltraEdit 10.2 for modifying the templating.cfg files. This new version by default adds a BOM at the beginig of the file when it is saved. To disable this features go to Advanced->Configuration->General and uncheck the following options.
1. Write UTF-8 BOM header to all UTF-8 files when saved.
2. Write UTF-8 BOM on all new files created with UltraEdit
Reopen UltraEdit and save your file again. The character should be gone.
-koti
TechAspect