We did slient new installation of TS 7.4.1 on linux box and Ui is not coming after installation is completed.
It says HTTP Status 404 - /iw-cc/command/iw.ui
We have gone throug iwserver.log, trace.log and iwutild.log.
The below error from serverlog and iwJboss.log is similar:-
2014-08-20 12:05:23,574 ERROR [STDERR] 2014-08-20 12:05:23,573 [JMSBridge] ERROR com.interwoven.serverutils100.utild.UtildConnectionFactory () - openSession error:
com.interwoven.hopi.HopiException: Bad write in server skeletons
at com.interwoven.hopi.HopiContext.sendData_(HopiContext.java:797)
at com.interwoven.utild.utild_.Connect(utild_.java:305)
at com.interwoven.utild.Utild.openSession(Utild.java:88)
at com.interwoven.serverutils100.utild.UtildConnectionFactory.makeObject(UtildConnectionFactory.java:77)
at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:974)
at com.interwoven.serverutils100.utild.UtildClient.borrowObject(UtildClient.java:85)
at com.interwoven.serverutils100.utild.UtildClient.getFileLastModDate(UtildClient.java:540)
at com.interwoven.serverutils100.IWConfigFileImpl.refresh(IWConfigFileImpl.java:108)
at com.interwoven.serverutils100.IWConfigFileImpl.<init>(IWConfigFileImpl.java:98)
at com.interwoven.serverutils100.IWConfig.<init>(IWConfig.java:131)
at com.interwoven.serverutils100.IWConfig.getConfig(IWConfig.java:77)
at com.interwoven.bridge100.TJMSBridge.init(TJMSBridge.java:295)
at com.interwoven.bridge100.TJMSBridge.run(TJMSBridge.java:133)
Caused by: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:882)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1188)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:654)
at com.sun.net.ssl.internal.ssl.AppOutputStream.write(AppOutputStream.java:100)
at java.nio.channels.Channels$WritableByteChannelImpl.write(Channels.java:296)
at com.interwoven.hopi.HopiChannel.write(HopiChannel.java:333)
at com.interwoven.hopi.HopiContext.sendData_(HopiContext.java:792)
... 12 more
Caused by: java.io.EOFException: SSL peer shut down incorrectly
at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:462)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:863)
... 18 more
2014-08-20 12:05:23,574 ERROR [STDERR] 2014-08-20 12:05:23,574 [JMSBridge] ERROR com.interwoven.serverutils100.IWConfigFileImpl () - Opening connection to utility daemon has failed 3 times
2014-08-20 12:05:23,574 ERROR [STDERR] 2014-08-20 12:05:23,574 [JMSBridge] ERROR com.interwoven.serverutils100.IWConfigFileImpl () - encounter an error when borrowing object from pool
com.interwoven.serverutils100.utild.UtildClientException: encounter an error when borrowing object from pool
at com.interwoven.serverutils100.utild.UtildClient.borrowObject(UtildClient.java:91)
at com.interwoven.serverutils100.utild.UtildClient.getFileLastModDate(UtildClient.java:540)
at com.interwoven.serverutils100.IWConfigFileImpl.refresh(IWConfigFileImpl.java:108)
at com.interwoven.serverutils100.IWConfigFileImpl.<init>(IWConfigFileImpl.java:98)
at com.interwoven.serverutils100.IWConfig.<init>(IWConfig.java:131)
at com.interwoven.serverutils100.IWConfig.getConfig(IWConfig.java:77)
at com.interwoven.bridge100.TJMSBridge.init(TJMSBridge.java:295)
at com.interwoven.bridge100.TJMSBridge.run(TJMSBridge.java:133)
Caused by: com.interwoven.serverutils100.utild.UtildClientException: openSession error:Bad write in server skeletons
at com.interwoven.serverutils100.utild.UtildConnectionFactory.makeObject(UtildConnectionFactory.java:80)
at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:974)
at com.interwoven.serverutils100.utild.UtildClient.borrowObject(UtildClient.java:85)
... 7 more
Caused by: com.interwoven.hopi.HopiException: Bad write in server skeletons
at com.interwoven.hopi.HopiContext.sendData_(HopiContext.java:797)
at com.interwoven.utild.utild_.Connect(utild_.java:305)
at com.interwoven.utild.Utild.openSession(Utild.java:88)
at com.interwoven.serverutils100.utild.UtildConnectionFactory.makeObject(UtildConnectionFactory.java:77)
... 9 more
Caused by: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:882)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1188)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:654)
at com.sun.net.ssl.internal.ssl.AppOutputStream.write(AppOutputStream.java:100)
at java.nio.channels.Channels$WritableByteChannelImpl.write(Channels.java:296)
at com.interwoven.hopi.HopiChannel.write(HopiChannel.java:333)
at com.interwoven.hopi.HopiContext.sendData_(HopiContext.java:792)
... 12 more
Caused by: java.io.EOFException: SSL peer shut down incorrectly
at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:462)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:863)
... 18 more
2014-08-20 12:05:23,574 ERROR [STDERR] 2014-08-20 12:05:23,574 [JMSBridge] ERROR com.interwoven.serverutils100.IWConfigFileImpl () - SEVERE FAILURE: Server stopping because connection to utild cannot be opened.
2014-08-20 12:05:23,576 INFO [org.jboss.system.server.Server] Runtime shutdown hook called, forceHalt: true
2014-08-20 12:05:23,578 INFO [org.jboss.system.server.Server] JBoss SHUTDOWN: Undeploying all packages
2014-08-20 12:05:23,582 INFO [STDOUT] Error: file not found: /opt/Autonomy/TeamSite/servletd/conf/ssl_cert/private/key.pem
2014-08-20 12:05:53,630 INFO [STDOUT] Error: file not found: /opt/Autonomy/TeamSite/servletd/conf/ssl_cert/private/key.pem
The log from iwutild.log:-
[Wed Aug 20 11:43:57 2014] *** iwutild locale is --> English_UnitedStates.US-ASCII@Binary
[Wed Aug 20 11:43:57 2014] Started Hopi server with 64 threads
[Wed Aug 20 11:43:57 2014] Hopi http listener on port 6688
[Wed Aug 20 11:43:57 2014] Hopi https listener on port 6689
[Wed Aug 20 11:43:57 2014] Hopi server with length of listen backlog 128
[Wed Aug 20 11:47:32 2014] iwutildstop: Stopped iwutildstart script
[Wed Aug 20 11:47:33 2014] iwutildstop: Stopped iwutild
[Wed Aug 20 11:47:33 2014] Stopped Hopi manager
[Wed Aug 20 11:50:33 2014] iwutildstart: Starting iwutild daemon
[Wed Aug 20 11:50:33 2014] *** iwutild locale is --> English_UnitedStates.US-ASCII@Binary
[Wed Aug 20 11:50:33 2014] Started Hopi server with 64 threads
[Wed Aug 20 11:50:33 2014] Hopi http listener on port 6688
[Wed Aug 20 11:50:33 2014] Hopi https listener on port 6689
[Wed Aug 20 11:50:33 2014] Hopi server with length of listen backlog 128
The log from iwtrace.log :-
[Wed Aug 20 11:50:35 2014] WARNING: Please contact Interwoven for a new license key soon.
[Wed Aug 20 11:50:35 2014] License Info --> Number of Stores: NoLimits
[Wed Aug 20 11:50:35 2014] License Info --> Number of CPUs: NoLimits
[Wed Aug 20 11:50:35 2014] License Info --> Server Type: 'Unknown'
[Wed Aug 20 11:50:35 2014] License Info --> Expiration Date: 'Unknown'
ERROR: no valid submit config file found in the current configuration (/opt/Autonomy/TeamSite/conf/events/submit.conf, /opt/Autonomy/TeamSite/local/config/submit.cfg, /opt/Autonomy/TeamSite/config/submit.cfg, /opt/Autonomy/TeamSite/local/config/submit.cfg) (2)
ERROR: no valid autoprivate file found in the current configuration (/opt/Autonomy/TeamSite/conf/events/autoprv.txt, /opt/Autonomy/TeamSite/local/config/autoprivate.cfg, /opt/Autonomy/TeamSite/config/autoprivate.cfg, /opt/Autonomy/TeamSite/local/config/autoprivate.cfg) (2)
[Wed Aug 20 11:59:37 2014] License Info --> Number of Stores: NoLimits
[Wed Aug 20 11:59:37 2014] License Info --> Number of CPUs: NoLimits
[Wed Aug 20 11:59:37 2014] License Info --> Server Type: 'Unknown'
[Wed Aug 20 11:59:37 2014] License Info --> Expiration Date: 'Unknown'
[Wed Aug 20 11:59:37 2014] Wakeup License Monitor
[Wed Aug 20 11:59:37 2014] WARNING: Please contact Interwoven for a new license key soon.
[Wed Aug 20 11:59:37 2014] Utility Daemon Enabled
[Wed Aug 20 11:59:37 2014] Log Permissions Disabled
[Wed Aug 20 11:59:37 2014] Log Authentication Disabled
[Wed Aug 20 11:59:37 2014] User database enabled
[Wed Aug 20 11:59:37 2014] Log Config Mirror Disabled
[Wed Aug 20 11:59:37 2014] Login Daemon Enabled
[Wed Aug 20 11:59:37 2014] Group Buffer size set to 8192
[Wed Aug 20 11:59:37 2014] group_list_update_interval is set to 10 minutes
[Wed Aug 20 12:09:37 2014] WARNING: Please contact Interwoven for a new license key soon.
[Wed Aug 20 12:19:37 2014] WARNING: Please contact Interwoven for a new license key soon.
[Wed Aug 20 12:29:37 2014] WARNING: Please contact Interwoven for a new license key soon.
[Wed Aug 20 12:39:37 2014] WARNING: Please contact Interwoven for a new license key soon.
The log from iwserver.log :-
iwetcboot: Done saving changes.
iwmount: Unmounting /opt/iwmnt/default...
iwmount: Unmounting /opt/iwmnt/iwadmin...
iwetcboot: Running iwstop ...
iwstop: waiting for the server to shutdown... \c
done
iwauthdstop: Stopped iwauthdstart script ...\c
DONE
iwauthdstop: Stopped iwauthend ...\c
DONE
iwutildstop: Stopped iwutildstart script ...\c
DONE
iwutildstop: Stopped iwutild ...\c
DONE
iw.server: ---------- STOPPED: Wed Aug 20 11:47:34 EDT 2014
iwuiboot: ---------- STARTING: Wed Aug 20 11:49:50 EDT 2014
Operation not permitted at /opt/Autonomy/TeamSite/iw-webd/bin/iwwebd_conf.ipl line 224.
iwuiboot: ---------- Web Daemon STARTED: Wed Aug 20 11:49:50 EDT 2014
iwuiboot: ---------- Proxy Server STARTED: Wed Aug 20 11:49:50 EDT 2014
iw.server: ---------- STARTING: Wed Aug 20 11:50:33 EDT 2014
iwetcboot: Running iwstart /opt/iw-store in /opt/Autonomy/TeamSite
iwstart: The events log file is /opt/Autonomy/TeamSite/local/logs/iwevents.log
iwstart: Starting iwutildstart script (User: root)...
iwstart: Starting iwauthdstart script...
iwstart: Spawning iwserver.linux (trace file: /opt/Autonomy/TeamSite/local/logs/iwtrace.log)...
iwstart: Waiting up to 60 seconds for iwserver to come up...\c
no element found at line 1
READY
iwmount: Mounting /opt/iwmnt/default...
iwmount: Mounted /opt/iwmnt/default.
iwmount: Mounting /opt/iwmnt/iwadmin...
iwmount: Mounted /opt/iwmnt/iwadmin.
Application Container Service is already running (pid 14942).
iwuiboot: ---------- STARTING: Wed Aug 20 11:50:36 EDT 2014
Interwoven Web Daemon starting ...
Operation not permitted at /opt/Autonomy/TeamSite/iw-webd/bin/iwwebd_conf.ipl line 224.
iwuiboot: ---------- Web Daemon STARTED: Wed Aug 20 11:50:36 EDT 2014
Interwoven Proxy Server starting ...
iwuiboot: ---------- Proxy Server STARTED: Wed Aug 20 11:50:36 EDT 2014
iw.server: ---------- STARTED: Wed Aug 20 11:50:36 EDT 2014
iwuiboot: ---------- STOPPING: Wed Aug 20 11:59:37 EDT 2014
/opt/Autonomy/TeamSite/iw-webd/bin/iw.webd stop: iwwebd stopped
iwuiboot: ---------- STOPPED: Wed Aug 20 12:00:08 EDT 2014
iwuiboot: ---------- STARTING: Wed Aug 20 12:04:08 EDT 2014
Operation not permitted at /opt/Autonomy/TeamSite/iw-webd/bin/iwwebd_conf.ipl line 224.
iwuiboot: ---------- Web Daemon STARTED: Wed Aug 20 12:04:08 EDT 2014
iwuiboot: ---------- Proxy Server STARTED: Wed Aug 20 12:04:09 EDT 2014
Please let us know is this issue in the installation or some licence is expired. I know after 48 hours we need to update licence but 48 hrs is not yet done so we are not sure why teamsite UI is not coming.
Any suggestion. Appreciate your help!!!!
Regards
Gopi