Unable to retrieve workflows in TeamSite 7.3.2 due to some javascript error



I am trying to retrieve workflows in TeamSite 7.3.2 but unable to load. Just seeing "Contacting server..." and workflows never load. This is happening very recently from last week, I used to load workflows fine before.


I have also looked at wfm.log but did not find any errors.When I debugged with Chrome Developer tool, I am seeing the below JS error. I am not sure why ext JS error happening now.


Uncaught DOMException: Failed to execute 'insertAdjacentHTML' on 'Element': The provided markup is invalid XML, and therefore cannot be inserted into an XML document.
at Object.insertHtml (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:6052)
at constructor.insertRows (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:11:150217)
at constructor.onAdd (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:11:157463)
at h.Event.fire (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:3699)
at constructor.fireEvent (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:687)
at constructor.add (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:311999)
at constructor.loadRecords (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:318415)
at constructor.loadData (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:318572)
at constructor.loadData (https://tcm.qa.snapfish.com/iw-core/extjs/ext-all.js:7:342937)
at constructor.<anonymous> (https://tcm.qa.snapfish.com/iw-wfm/wfmutils.js:1:120781)


Is anyone facing with same issue? Please suggest how can I get rid of this error.


Vinod Goud



    Found the issue and fixed it.


    Here is what I fixed:


    1. When I tried to retrieve workflow models, I noticed that four workflows loaded in the popup and it got struck loading from fifth model onwards.


    2. I have examined the response of below API call and keenly observed fifth model JSON data and suspected some issue with lastModifiedBy attribute "<no user>" ( This can be an invalid XML )




        "modelName": "Configurable_Author_Assignment.ipm",
        "state": "Draft",
        "lastModifiedBy": "<no user>",
        "owner": "iwts",
        "vpath": "//qa-teamsite-1/iwadmin/main/workflowModels/WORKAREA/iw-wa/Models/Configurable_Author_Assignment
        "lastModificationDate": "Mon Apr 13 22:51:17 GMT-08:00 2015",
        "isModifiedInWA": false


    3. Connected to the server and went to the path where that model exists and ran following commands.




    chmod 664 Configurable_Author_Assignment.ipm

    chmod 664 Configurable_Author_Assignment.json


    4. Now tried to retrieve the workflow models and able to load the workflows in the popup.



    Vinod Goud


  • I had the same issue with sticky bit:

    -rw-rwSr-- 1 iwguser nobody 3243 Feb 27 21:03 PRDDEV1.ipm
    -rw-rwSr-- 1 iwguser nobody 3832 Feb 27 21:03 PRDDEV1.json
    -rw-rwSr-- 1 iwguser nobody 3245 Feb 28 14:09 PRDQA.ipm
    -rw-rwSr-- 1 iwguser nobody 3841 Feb 28 14:09 PRDQA.json

    After remove it (chmod g-s *), it was ok

TeamSite Developer Resources

  • Docker Automation

  • LiveSite Content Services (LSCS) REST API

  • Single Page Application (SPA) Modules

  • TeamSite Add-ons

If you are interested in gaining full access to the content, you can register for a My Support account here.
OpenText CE Products