The community of Analytics developers are invited to follow and participate in the developer network.
OpenText technical experts collaborate with supported customers and partners in the Magellan product area.

Report Parameter from Library Question

ericsmithericsmith Junior Member
edited December 31, 1969 in Designing reports
Using BIRT RCP Designer 2.2.1.

When I add report parameters from my report.library through the designer, then update my dataset to use the parameters, I've noticed that sometimes BIRT duplicates the underlying datasets used by the parameters in my local report - rather than using the datasets in the library that they reference. When this happens, I can't get the report to run correctly - the parameter entry drop down lists are always empty.

When I check the data in the local datasets that were "auto created", they are pulling in data.

Anyone know why is BIRT auto-creating data sets rather than using the library data-sets and how to avoid this?

When BIRT uses the library data sets, reports run properly and it's much cleaner - no duplicated data sets.

Comments

  • ericsmithericsmith Junior Member
    edited December 31, 1969
    After some testing, I see that this only happens when using library parameters in a local report data set. If I use a library data set, BIRT does not auto-create the additional datasets used by the parameters.

    I was able to solve the problem by dragging in the two library datasets the parameters used into my local report and things started working.

    This seems like a bug though - either the auto-created local datasets should work, or it should know to use the linked library data sets.
Sign In or Register to comment.