Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
File List Deployments Hang
Ninerfan
I'm getting File List deployments that hang. Meaning that if I do a iwodserverreset it shows a dozen or so deployments as SENDING and in the OD Admin GUI it shows the deployment as "Running". Below is the error from the log indicating the deployment stopped.
This seems to be about 1 out of 30 deployments where this happens. I am on a solaris 2.8 system deploying to Win2K.
Any advice is appreciated.
client: LIB: Component Version (5.6.0.0.0 Build 17405 Interwoven 20030306)
client: Buffer Size (8000)
client: Protocol Version(5.0) OK
client: Connection Id(id=0)
client: Transaction Mode: ON
client: Mode(normal)
client: Protocol(rcp)
client: Hostname(161.69.6.156)
client: User(root)
client: Name(.od_review25198.REVIEW.sncqaweb2)
client: BEGINNING Transactional Deployment
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 After SETUP, res=0
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 exiting setup
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 entering awaiting-dotask
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 still waiting for 0
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 exiting awaiting-dotask
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 entering dotask
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 COMPARE
client: Options: rm_readonly date_different svr_try_count=2 svr_try_interval=20 ignore_acls do_manifest_for_dnr
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 After COMPARE, res=0
ENG: 2003-05-30 14:00:13 PDT GMT-07:00 Thread-39 PRECOMMIT
client: DEPLOYING - [/iwmnt/default/main/Web_Sites/us/WORKAREA/Corporate] to [e:/inetpub/wwwroot/review1]
client: Filelist=[/opt/iwov/iw-home/tmp/filelist.25192]
client: Sending [./us/promos/entercept.htm] [reason file_list] ERROR: File(/iwmnt/default/main/Web_Sites/us/WORKAREA/Corporate/us/promos/entercept.htm) failure: bytes-read=-1 bytes-expected=6271.
Find more posts tagged with
Comments
Migrateduser
Anything running on the target Windows box that could be locking files during the deployment, such as IIS? If so, the server try count of 2 may not be enough.
Also make sure the MS Indexing Service isn't running during the deployment, since that could also tend to lock files (including temporary ones created by OpenDeploy) during the deployment, which would cause failures.
Todd Scallan
Group Product Manager
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
squint
Has anyone solved this problem?
I am getting the exact same error.. but My Server is running on Solaris and my receivers are running on SuSE Linux. ?/
Any ideas would be appreciated .
Thanks.
Migrateduser
Which version of OD? Which versions of operating systems?
Any chance you are running concurrent deployments that attempt to update the same files?
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
Migrateduser
Given this log msg,
client: Sending [./us/promos/entercept.htm] [reason file_list] ERROR: File(/iwmnt/default/main/Web_Sites/us/WORKAREA/Corporate/us/promos/entercept.htm) failure: bytes-read=-1 bytes-expected=6271.
I can suggest a couple possibilities:
1) you are using /iwmnt which is TS's cached mount point,
you might consider using /.iwmnt, the non-cached mount point.
2) Is the file you are deploying, subject to be changing even when deploying?
...given that you are deploying from an uncontrolled changing Workarea.