Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
WARNING: Effective heartbeat clock interval was: 19 seconds.
dianbo
Can anyone give me some suggestions for this warning message. It appears when the report cost a long time to load data, as i described in page <a class='bbc_url' href='
http://www.birt-exchange.org/forum/deploying-birt-reports-deployment-kit-iserver-express/16698-how-set-max-request-time.html'>http://www.birt-exchange.org/forum/deploying-birt-reports-deployment-kit-iserver-express/16698-how-set-max-request-time.html</a>
.
Find more posts tagged with
Comments
WeiZhao
Hi dianbo:
This warning usually means your system is too busy and it takes longer to send heartbeat message than usual. Failure to receive multiple heartbeat messages in row might cause the iserver to mistakenly restart related Java view server which could cause request failure.
To avoid that, you will need to properly configure your system so that it's not overloaded. For example, if a single machine is not enough to handle the load of your application, you might need to consider creating a cluster of two or more machines.