Over the past weeks I have been struggling with the famous memory problem PermGen when I deployed my report to my Tomcat 5.2.23. After a few clicks in the report there is still always a similar error to the following:<br />
<br />
"Report generation failed. Cause: There are errors evaluating script "params["myParams"].value": PermGen space"<br />
<br />
Those errors always refer to PermGen which means there isn't enough memory to execute the report. <br />
If you google this problem and/or look for it in BIRT exchange, most of the time you are recommended to enlarge the memory in the Java Options. I did that with several different adjustments in my catalina.sh file - without success though... <br />
<br />
Example:<br />
JAVA_OPTS="$JAVA_OPTS -Xms256M -Xmx1024M -XX:MaxPermSize=256m -XX:PermSize=128m -XX:+AggressiveHeap"<br />
<br />
Links:<br />
<br />
<a class='bbc_url' href='
http://www.samaxes.com/2007/10/classloader-leaks-and-permgen-space/'>Classloader leaks and PermGen space - samaxes</a><br />
<br />
<a class='bbc_url' href='
http://blogs.sun.com/fkieviet/entry/classloader_leaks_the_dreaded_java'>Frank Kieviet : Weblog</a><br />
<br />
<a class='bbc_url' href='
http://blogs.sun.com/fkieviet/entry/how_to_fix_the_dreaded'>Frank Kieviet : Weblog</a><br />
<br />
These articles on the PermGen Memory issue tell that extending the memory does't solve the problem but only delay it. The real problem is that still reachable classes are being piled in the heap memory and therefore are not collected by the Garbage Collector. <br />
<br />
Regarding this post <a class='bbc_url' href='
https://www.blogger.com/comment.g?blogID=14521551&postID=222993167941327241'>https://www.blogger.com/comment.g?blogID=14521551&postID=222993167941327241</a> , it claims that the file "scriptContext.class" in the jar file "coreapi.jar" has to be fixed to avoid the heaping of the classes and to prevent a memory leak. But I dont know exactly what has to be done. Do you have any solution for that??<br />
<br />
On my tomcat only BIRT Viewer with my report and a small login application for access control are running and it keeps breaking down because of memory reasons.<br />
<br />
Thank you very much in andvance<br />
<br />
Kind regards<br />
<br />
work_ph