Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
BIRT 2.5.2 Deployment could not be started in tomcat 5.5 with jre 1.5
udezonan
Hello
I'm Using Myeclipse to add BIRT reporting capability to my web application
when i run locally it work fine
but when i deploy it to the server the app cannot start
i do some tweaking to the web.xml and found that if i remove the birt listener,servlet and servlet-mapping my app can start
but render my report useless
i use jre 1.6, BIRT 2.5.2 and tomcat 5.5 on windows vista for development
for the server i use tomcat 5.5 and jre 1.5 on red hat linux.
i know the different of jre ver between development and deployment
but i thought BIRT minimum requirement is jre 1.5?
Find more posts tagged with
Comments
JasonW
Can you set the log level in the web.xl to FINE and see if you get any errors in the log file?
Jason
udezonan
Hai
i got this from stdout.log when i downgrade my local java from 1.6 to 1.5
09:47:12,269 ERROR [/cuba]:3768 - Exception sending context initialized event to listener instance of class org.eclipse.birt.report.listener.ViewerServletContextListener
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:1847)
at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:873)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1326)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1205)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:316)
at org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)
at org.eclipse.birt.report.listener.ViewerServletContextListener.contextInitialized(ViewerServletContextListener.java:62)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:825)
at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:714)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:490)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:448)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
this one i get from the linux server that using java 1.5 and tomcat 5.5
Sep 2, 2010 9:03:33 AM org.apache.catalina.core.NamingContextListener lifecycleEvent
SEVERE: Creation of the naming context failed: javax.naming.NamingException: Context is read only
Sep 2, 2010 9:03:35 AM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Sep 2, 2010 9:03:35 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/cuba] startup failed due to previous errors
udezonan
never mind i've solve this issue
i just upgrade the server jre to 1.6
and everything work fine
but an explanation on why the cause
of the problem is much appreciated
JasonW
It looks like some of the viewer code was getting compiled with the jdk 6 version. If you are using the WTP integration, maybe some integration code was getting compiled in your workspace.
Jason
udezonan
yup i'm using wtp
i just surprise because my other class can work
i have set the compliance level to 1.5 but the java ver install is 1.6
i'll just have to be more careful next time thanks for your help