Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
ERROR:00022: Invalid argument
RichieRich
Last night our TeamSite server took it upon it's self to reboot. We are not sure what might be the cause of this, but we have been digging into the logs to try and locate if this issue is related to TeamSite. Early today we tried to push some content out via OpenDeploy and a workflow which was working for over a year without flaw and we ran into a problem.
Nothing was deployed and no log files were modified to reflect this issue. The only log file I noticed that contained *any* informatino was iwtrace.log under /var/adm. (We are on solaris TS 5.5.2 Open Deploy.)
The log contained the following:
***ERROR - Starting deployment.
ERROR:00022: Invalid argument
***ERROR - Starting deployment.
ERROR:00022: Invalid argument
I am unable to locate what "ERROR:00022" means and what might cause it? I tried searching the forum and also their support web site.
Does anyone have any clue what this error means, why it happens and what logs to check besides iwserver, iwevents.log, andiwtrace?
Thank you,
Richie Rich
-[ Richie Rich ]-
Find more posts tagged with
Comments
nipper
From the CLT manual Error 22 is an NFS error.
Are you using Unix ? Do a df -k see if you see both mounts, /iwmnt/default and /.iwmnt/default
Are you seeing stale NFS handle anywhere ?
Andy
RichieRich
I did a Disk free and there is around 25% space free (600mbs Free).
What is odd, is that last night the TeamSite had a cold reboot for no reason. Just about 20mins ago I stopped and start both TeamSite and OD to ensure a clean shut down and start up. After doing that everything was fine.
-[ Richie Rich ]-
nipper
This error likely had nothing to do with what happened, rather was just a symptom.
We have TS servers bit the dust & when iwserver goes away, we get stale NFS handles on anything that tries to touch /iwmnt (similar to your Error 22). They go away when TS is brought back up.
You need to look in the logs again (before the Error 22), anything say Segmentation Fault, Core Dump or Bus Error ? Look for core files: as root run:
find / -name core -print | xargs ls -l
Look for any files with the time stamp of when it when down, if there are any, fo a file on it & if it is IW, open a case with support.
HTH
Andy