Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
The viewing session has expired for the first time login
ambujk
Hi All,
we are using
Tomct 6,
Jdk 1.5
Birt 2.3.
We are able to run the reports (simultaneoulsy at a time in single page using iframes) fine but the problem is whenever we start the tomcat and login into the application in one of the reports we are getting the following error but when we refresh the browser the reports are working fine.
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
java.lang.IllegalStateException: The viewing session has expired.
org.eclipse.birt.report.session.ViewingSession.checkExpired(ViewingSession.java:105)
org.eclipse.birt.report.session.ViewingSession.lock(ViewingSession.java:142)
org.eclipse.birt.report.session.ViewingSessionManager$ViewingSessionWrapper.lock(ViewingSessionManager.java:143)
org.eclipse.birt.report.servlet.BaseReportEngineServlet.doGet(BaseReportEngineServlet.java:172)
javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.eclipse.birt.report.servlet.BaseReportEngineServlet.service(BaseReportEngineServlet.java:116)
org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.10 logs.
Find more posts tagged with
Comments
There are no comments yet