Hello all,<br />
<br />
I've a problem with the deploying of a connection profile to the iServer. Ok. This topic isn't new and maybe I failed in understanding about the functionality. In that case, the solution should be easy.

<br />
<br />
<strong class='bbc'>What we have (environment):</strong><br />
We installed as version 11:<br />
- iServer Express (Trial version)<br />
- BIRT Professional Designer<br />
<br />
OS is Windows 2008 R2 64-Bit (German language). Labels and logs of the Actuate products are partially shown in German language.<br />
<br />
Major database is Oracle ( version 9 - 11). The oracle driver is copied to the driver folder in eclipse and iServer (e.g. org.eclipse.birt.report.data.oda.jdbc_2.6.1.****).<br />
<br />
Also we have a lot of implemented EclipseBIRT reports. These reports uses the connection profiles by a parameter. We create the ServerProfiles.dat and the report choose the connection while executing from there. The reports are not configured to a fix profile file. On customer side we just deploy the reports in a JBoss folder. In this envronment the service manage the connection via several internal xml files.<br />
<br />
Also, the reports always have a fix database connection implemented as JDBC data source. We use it as default connection and test connection for the implementation.<br />
<br />
The reports are implemented in version 2.6.1 The Professional Designer can execute them without any errors. The profiles are used as expected from workspace.<br />
<br />
<br />
<strong class='bbc'>What we want:</strong><br />
- Deploy the connection profile to the iServer<br />
- The reports uses the profiles on iServer like we known from JBoss without changing the design<br />
<br />
<strong class='bbc'>What we've done:</strong><br />
Export the ServerProfile.dat from Professional Designer with this syntax:<br />
<br />
<pre class='_prettyXprint _lang-auto _linenums:0'>
<?xml version="1.0" encoding="UTF-8"?>
<DataTools.ServerProfiles version="1.0">
<profile autoconnect="No" desc="" id="5d017c41-b163-11dd-8808-9d53d559e35a" name="myConnection" providerID="org.eclipse.birt.report.data.oda.jdbc">
<baseproperties>
<property name="odaDriverClass" value="oracle.jdbc.OracleDriver"/>
<property name="odaURL" value="jdbc:oracle:thin:
@myServer:1521:myData"/>
<property name="odaPassword" value="myuser"/>
<property name="odaUser" value="mypwd"/>
</baseproperties>
</profile>
.
.
.
</DataTools.ServerProfiles>
</pre>
<br />
The file location was set into the configuration file acserverconfig.xml in the Template tag:<br />
<pre class='_prettyXprint _lang-auto _linenums:0'>
.
.
.
<Templates>
<Template
Name="myServer"
LogSize="100000"
NumLogs="3"
PMDPort="8100"
LogLevel="7000"
ActuateBuild="110B100926"
ActuateVersion="11"
ConnConfigFile="C:\Actuate11\ConnProfile\ServerProfiles.dat"
AppContainerPort="8900"
RequesterRSAPIVolume="myServer">
<ReportingService
LogSize="100000"
.
.
.
</pre>
<br />
<br />
After changing the configuration file we restart the iServer. We export encrypted and non-encrypted version of the ServerProfiles.dat to the mentioned folder.<br />
<br />
<strong class='bbc'>What we've got:</strong><br />
The iServer throws an error while parsing ServerProfiles.dat because the file doesn't start with the root tag <Config>. The encrypted version of this file throws an error because it cannot be parsed ("[Error] Unexpected exception: org.xml.sax.SAXParseException: Content is not allowed in prolog.").<br />
<br />
While running the reports only the default connection is used.<br />
<br />
<br />
What we've make wrong? Why does the iServer needs a <Config> tag or why the Designer doesn't export it? Is it the wrong way to deploy the profiles? Why the encrypted file cannot be parsed by the iServer?<br />
<br />
<br />
In all documents and forum threads we didn't found any other hints about this topic we didn't try anymore. So we have no idea anymore.<br />
<br />
<br />
Sorry for the long posting

<br />
<br />
Best regards, Michael