Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
IBM Turbo Error
agubbi21
Hi,
We are kind of stuck in the middle of our TeamTurbo installation. While creating a lightweight sandbox pool, we are encountering a error as follows:
AddServer
Status: IBM TeamTurbo encountered an unexpected error while trying to connect to the primary WebSphere server: The WebSphere Server returned an error: Could not create lightweight Sandboxpool.ApplicationCrawler.collapseEarFile - Failed
Reason:
com.interwoven.turbo.ibm.SandboxException: Could not create lightweight Sandboxpool.ApplicationCrawler.collapseEarFile - Failed
at com.interwoven.turbo.ibm.SandboxServlet.createSandboxPool(SandboxServlet.java:514)
at com.interwoven.turbo.ibm.SandboxServlet.processRequest(SandboxServlet.java:164)
at com.interwoven.turbo.ibm.SandboxServlet.doPost(SandboxServlet.java:143)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.ibm.servlet.engine.webapp.SingleThreadModelServlet.service(SingleThreadModelServlet.java:89)
at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(StrictLifecycleServlet.java:167)
at com.ibm.servlet.engine.webapp.IdleServletState.service(StrictLifecycleServlet.java:297)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(StrictLifecycleServlet.java:110)
at com.ibm.servlet.engine.webapp.ServletInstance.service(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(ServletManager.java:913)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:678)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:331)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.forward(WebAppRequestDispatcher.java:117)
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward(WebAppInvoker.java:134)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:239)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.invocation.CacheableInvocationContext.invoke(CacheableInvocationContext.java:106)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:154)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:323)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:252)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:137)
We are not sure what we are doing wrong.
Please help!!!!
Thanks in advance.
AG
Find more posts tagged with
Comments
Migrateduser
Couple things to look for:
1) Make sure WebSphere has read/write access to the TS file system containing your application
- Permission issues are the number one issue when trying to get TeamTurbo up and running
2) A lightweight sandbox requires the application to be submitted to staging for the branch designated as the lightweight sandbox pool. The EJBs are then used from staging on the branch and the JSPs/servlets are taken from the respective workarea being assigned a lightweight sandbox.
3) If you don't have internet access from the WAS machine, it may cause problems as the Turbo component running on WAS looks to the web for certain DTDs
- Pre TeamTurbo 5.5.2 this was an issue and a workaround is available on support
- TeamTurbo 5.5.2 resolved this issue
The #1 issue customers have is getting the permissions settings for WebSphere access to TS file system correct. If you're positive you have this setup right, and the correct security settings on WAS (per the product guide) then start looking at the other items I mentioned.
Hope this helps. If it doesn't I suggest opening a case on support if you haven't and recommend you ask support for a Request for Engineering Assistance as the issues with WAS-TeamSite encountered in TeamTurbo require a great deal of expertise with both systems.
Darren
Interwoven Product Management.