Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
Out of memory error
jmcinor
I have a report that fetches 5580 records and completes in under 20 seconds. When I add an "Always" pagebreak to a group footer, the report runs for over 5 minutes and eventually fails with:
Jan 28, 2012 5:03:29 PM org.eclipse.birt.report.engine.api.impl.RunTask doRun
SEVERE: There is insufficient memory to execute this report.
If I leave the "Always" page break but constrain the select to fewer records, the report finishes. ANy thoughts? (this is a new installation of BIRT/Tomcat on Debian)
thanks,
j
Find more posts tagged with
Comments
mwilliams
Does it fail at a certain number of groups? Have you figured what the limit is?