Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OD doesn't deploy consistently
Renata
we're hoping maybe someone here can help us ...
Currently we're using OD to push files from TS server to a web server, the usual deployments. Sometimes the files come through sometimes they don't. There seems to be no consistency in this behaviour.
we do however get a java[17] error: too many files opened.
has anyone encountered a similar problem or the above error?
any hits are greatly appreciated!
Find more posts tagged with
Comments
Adam Stoller
Please provide more information:
1) What version of OpenDeploy (including service packs)
2) What version of TeamSite (including service packs)
3) What platform is your TeamSite / OpenDeploy Base Server
4) What platform is your Web Server / OpenDeploy Receiver
5) What Web Server software (and version) are you using?
6) Does OpenDeploy claim to have had no errors in its logfiles?
7) Have you looked at all the OpenDeploy logs to search for messages that might be related to the errors?
--fish
(Interwoven Senior Technical Consultant)
Renata
I've got the following system info so far:
OD - 5.5.1
TS - 5.5.2 on UNIX
Web server- webSphere/iPlanet on NT
in terms of errors, there are no errors, OD simply doesn't always recognize source files as modyfied. Could different server dates/time schedules have anything to do with that?
thanks ... R
Edited by Renata on 02/25/03 04:02 PM (server time).
Adam Stoller
Determining what gets deployed is based on the various configuration options specified in the deployment configuration file. You'd have to look at that to determine whether or not certain options need to be added or removed.
The combinations of all these variables make it difficult to try to diagnose within the forums without getting a bit more information. If you post (as an attachment) the deployment configuration file, it might help.
Different server dates/times could definitely be a factor. With so many time-servers available and software to use to synchronize machines with them, it is ridiculous (IMO) for any system in use at a company to NOT be using time synchronization software.
--fish
(Interwoven Senior Technical Consultant)
Migrateduser
are you kicking off deployments from a TS workflow?
there is a known TS issue wrt to external wf's.
and the "too many open files" error is one of the observed symptons.
Migrateduser
more context to add....
there is a TS bug which will be fixed in TS SP3.
another problem is a Sun /bin/ksh bug where ksh has a cap limit on number of open files... and invoking Java invokes /bin/ksh.
Adam Stoller
The 'java[17] error: too many files opened.' is because of some stupid (IMO) code in the java shell script, which as 3rd party code we were not inclined to change.
If you look at that script you'll see a line which looks something like this:
set FOO=`command` 2>1 > /dev/null
The redirecs are *outside* the back-ticks - and *that* is what causes the error message to appear. (there are two such lines in the script).
I don't believe this has anything to do with actual problems with the deployment.
--fish
(Interwoven Senior Technical Consultant)
eddie1
What do your log files say ?
Migrateduser
For the Sun ksh bug, try the following workaround for OD being invoked from TeamSite workflow:
Localized workaround for OD,
Change topline in <od-home>/jre/bin/.java_wrapper script
to use /usr/dt/bin/dtksh
General workaround which affects all ksh scripts
# mv /usr/bin/ksh /usr/bin/ksh.orig
# cp -p /usr/dt/bin/dtksh /usr/bin/ksh
RichieRich
We are currently having the same issue. I'm not sure what its root cuase is, but I ran ulimit -aH and see that we allow for 1024 open files. I feel compelled to bump this up via ulimit -n for nofiles (Number of files) but I fear if this is a bug that it might just gobble up the free FD (File Descriptors).
Is ths a known bug for solaris/unix boxs? I see alot of comments about what, but I think this is a bug in the product.
we use TS od 5.5.2 On Solaris.
Thank you,
-[ Richie Rich ]-
Migrateduser
It's been covered in previous threads, but probably worth restating here:
Bug 11839 is believed to be the root cause of the iwodstart CLT crashing when invoked from a TeamSite workflow due to FDs being consumed. A fix is provided in TeamSite 5.5.2 sp3.
In addition, a new non-Java based CLT can be used in place of iwodstart (and other iwod... CLTs) as of OD 5.6 SP1. This will help circumvent the OD/workflow failures caused by 11839 by eliminating the overhead associated with starting a new JVM for each command line invocation.
Todd Scallan
Group Product Manager
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com