Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
Birt Chart Excepption
bandi
Hi,<br />
<br />
I created charts report and while running the charts in production through tomcat server, i am getting following below error:<br />
<br />
<br />
HTTP Status 500 - <br />
<br />
<br />
<br />
type Exception report<br />
<br />
message <br />
<br />
description The server encountered an internal error () that prevented it from fulfilling this request.<br />
<br />
exception <br />
<br />
javax.servlet.ServletException: Servlet execution threw an exception<br />
org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)<br />
<br />
<br />
root cause <br />
<br />
java.lang.OutOfMemoryError: PermGen space<br />
<br />
<br />
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.32 logs.<br />
<br />
<br />
<br />
<br />
Apache Tomcat/6.0.32<br />
<br />
<br />
<strong class='bbc'>NOTE:- I am using birt 3.7.2 open source version.</strong><br />
<br />
<br />
Could you please help me out on this problem.<br />
<br />
<br />
Regards,<br />
Kiran
Find more posts tagged with
Comments
kclark
You should be able to increase your permgen size in catalina.sh or bat depending on your environment. You would need to find or add JAVA_OPTS to this file.<br />
<br />
<pre class='_prettyXprint _lang-auto _linenums:0'>JAVA_OPTS="-Djava.awt.headless=true -Dfile.encoding=UTF-8 -server -Xms1536m
-Xmx1536m -XX:NewSize=256m -XX:MaxNewSize=256m -XX:PermSize=256m
-XX:MaxPermSize=256m -XX:+DisableExplicitGC"</pre>
<br />
You can change the pergen space by increasing the amount with this flag -XX:PermSize=256m
bandi
Hi Kclark,<br />
<br />
I already changed the pergen space by increasing the amount with this flag -XX:PermSize=1024m<br />
still i am getting same error.<br />
<br />
<strong class='bbc'>Note:- In same server around 200 reports are running fine. Only Graphical charts are not running.</strong><br />
<br />
<br />
Any solution for this?...<br />
<br />
<br />
kiran