The community of Analytics developers are invited to follow and participate in the developer network.
OpenText technical experts collaborate with supported customers and partners in the Magellan product area.

Error when viewing report in Websphere Application Server 8.0

<p>I am trying to run a simple report built using BIRT 3.7.2 inside the IBM websphere application server 8.0 but it error out.</p><p> </p><p>I developed my simple report in Rational Application Development tool (which run on eclipse), and I setup my AS400 database connection inside the IDE.  I can run the preview from inside the IDE and I can see data in the report set.  But when I deployed it to the application server it error out with message: Table(id=163).  Can not load the report query:163.  Errors occurred when generating the report document for the report element with ID 163.</p><p> </p><p>Attached is my XML Source.</p><p> </p><p>Does anyone has similar experience running report in WAS8.0?</p><p>How do I solve this issue? Appreciate for all your input</p>

Comments

  • <p>That is because Maximo does not have the JDBC driver for AS/400. You will have to ask IBM if.how to deploy JDBC drivers to Maximo. I have not seen conclusive evidence that this is possible.</p>
  • I am looking for users that have successfully deployed to ibm as400 System i. I am have problems with displaying a chart, pie chart.

  • Could you please provide more details:

    Can you preview the data in a data set in BIRT?
    Can you run the report and display the data in a table?
    Can you get a chart to work on a report using a different data source, i.e. the Classic Models database that comes with BIRT?

    Regards,
    Jeff F.
    Sr. Technical Support Specialist
    OpenText
  • Hello,

    With the exception of displaying charts, pie charts and other graphs, all of BIRT works just fine with AS400 (System i).

    Can you preview data - YES
    Can you runn report - YES
    Can you get chart to work on .. different data source - YES. I use tables coming from the System i or Excel.

    The JDCS driver is complicated, but since I have IBM product RDi (Eclipse - Text editor for programming System i), I used that JT400 jar.
    There are other JT400 jars on System i. The server side implementation was done with Websphere Light (Can not access machine this minute, so I don't remember name. It is the version of Websphere that you do not have to pay for).

  • Hello again,

    Just to clarify. If I don't publish the report that has a pie chart, I can view it from within Rdi (Eclipse). Once I publish to System i, the report does not work.

  • Thanks for the answers. Do you have the ability to open a ticket with OpenText support? It would help to be able to do a WebEx and go through your setup.

    Regards,
    Jeff F.
    Sr. Technical Support Specialist
    OpenText
  • Hi,

    I am an independent programmer and have not contracted with Opentext. Are you saying that you are familiar with BIRT and would be able to solve the chart question? Does OpenText support BIRT?

    I use BIRT at client sites, so I would have to get permission to let you look at their data and set-up.

    Mindaugas

  • Hi Mindaugas,

    OpenText support monitors these forums when time permits. This forum gets questions about the Open Source and the commercial products.

    This might be helpful:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=219317

    Regards,
    Jeff F.
    Sr. Technical Support Specialist
    OpenText
  • Jeff,

    I did not do any of the things that the wiki mentioned, However, it is very helpful to get in contact with people that are involved in BIRT.
    When I get a chance I will start to carefully go through the ideas. Currently, I am leaning to exploring whether this is a version problem.

    Mindaugas

Sign In or Register to comment.