Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
Proxy for Activation
bfindlay
<p>Is is possible to specify an HTTP proxy to be used by the iHub server for activation (assuming http is being used to communicate to the Actuate servers)?</p>
<p> </p>
<p>If HTTP(S) is not used can you please specify which port(s) I need to open in my firewall to facilitate the activation?</p>
Find more posts tagged with
Comments
JFreeman
<p>Hello bfindlay,</p>
<p> </p>
<p>I am currently investigating the possibility of utilizing a proxy for activation.</p>
<p> </p>
<p>In parallel, could you please confirm for me the current behavior you are receiving within your environment when attempting to activate the product? Are you receiving an error? </p>
<p>If so, could you please provide the details of the error you are receiving?</p>
bfindlay
<blockquote class="ipsBlockquote" data-author="JFreeman" data-cid="129642" data-time="1406247944">
<div>
<p>Hello bfindlay,</p>
<p> </p>
<p>I am currently investigating the possibility of utilizing a proxy for activation.</p>
<p> </p>
<p>In parallel, could you please confirm for me the current behavior you are receiving within your environment when attempting to activate the product? Are you receiving an error? </p>
<p>If so, could you please provide the details of the error you are receiving?</p>
</div>
</blockquote>
<p> </p>
<p>The iHub server will accept the activation key but then when attempting to log in with administrator (and blank password) it will give a login failed. My server is in a DMZ and any connections inbound or outbound must be whitelisted.</p>
<p> </p>
<p>Alternatively, if you could provide the information on what connections need to be allowed outside of 8700/tcp that would work as well.</p>
JFreeman
<p>Where is the firewall located in this environment in which these ports are blocked?</p>
<p> </p>
<p>In a standard installation the information console (web application) and iHub server will be located on the same machine and thus communication between the information console and iHub should typically not require opening additional ports. However, this depends on other environment and system level configurations such as the host file.</p>
<p> </p>
<p>In a standard installation, ports 8100 and 8000 will be used for internal communication with the iHub.</p>
bfindlay
<blockquote class="ipsBlockquote" data-author="JFreeman" data-cid="129649" data-time="1406312883">
<div>
<p>Where is the firewall located in this environment in which these ports are blocked?</p>
<p> </p>
<p>In a standard installation the information console (web application) and iHub server will be located on the same machine and thus communication between the information console and iHub should typically not require opening additional ports. However, this depends on other environment and system level configurations such as the host file.</p>
<p> </p>
<p>In a standard installation, ports 8100 and 8000 will be used for internal communication with the iHub.</p>
</div>
</blockquote>
<p> </p>
<p>Determined that my issue was not related to firewall but rather to hostnames being specified in the configuration files but not /etc/hosts so connection to the Postgresql server was failing.</p>