Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Intelligence (Analytics)
Insufficient memory to execute a report
Smithdon
<div>I'm using <span style="color:rgb(40,40,40);font-family:'Source Sans Pro', sans-serif;">Birt 4.4.0 and </span><span style="color:rgb(40,40,40);font-family:'Source Sans Pro', sans-serif;">calling a Java class to run the reports. </span>The application is <span style="color:rgb(40,40,40);font-family:'Source Sans Pro', sans-serif;">deployed in Tomcat </span><span style="color:rgb(40,40,40);font-family:'Source Sans Pro', sans-serif;">and the sql statement returns not more than 100 lines but I'm getting </span><em>There is insufficient memory to execute this report</em> error.</div>
<div>
<div>
<pre class="_prettyXprint">
org.eclipse.birt.data.engine.executor.cache.SmartCacheHelper populateData
INFO: Time consumed by cache is: 0 second
org.eclipse.birt.report.engine.api.impl.EngineTask handleFatalExceptions
SEVERE: There is insufficient memory to execute this report.
</pre>
</div>
</div>
<div>I tried to increase both <span style="color:rgb(40,40,40);font-family:'Source Sans Pro', sans-serif;">heap space and permGen</span> memory on catalina.bat file by <em>-Xms1024m -Xmx4096m -XX:MaxPermSize=512m </em>but no luck.</div>
<div> </div>
<div>Any ideas?</div>
Find more posts tagged with
Comments
JFreeman
<p>How are you calling the Java class to run the report?</p>
<p>Can you provide your full JAVA_OPTS setting from the catalina.bat?</p>
<p> </p>
<p>Are you able to generate the exact same report from the BIRT Designer without issue?</p>
Smithdon
<p>Thank you for your reply.</p>
<p> </p>
<p>Yes, I can generate exact same report on the viewer. The problem is when it's deployed in tomcat.</p>
<div>
<p> </p>
<p>Here is the part of catalina.bat where memory is set. Also attached please find full catalina.bat file</p>
<pre class="_prettyXprint">
:doStop
shift
set ACTION=stop
set CATALINA_OPTS=-Xms2048m -Xmx4096m -XX:MaxPermSize=512m
goto execCmd</pre>
<p>The specific class used to call Birt <a data-ipb='nomediaparse' href='
https://github.com/joshlong/spring-birt/blob/master/spring-birt-integration/src/main/java/org/eclipse/birt/spring/core/AbstractSingleFormatBirtView.java'>https://github.com/joshlong/spring-birt/blob/master/spring-birt-integration/src/main/java/org/eclipse/birt/spring/core/AbstractSingleFormatBirtView.java#L278</a> (line
278)</p>
</div>
<div> </div>
<div>
<p>The java class and how it is called <a data-ipb='nomediaparse' href='
https://github.com/joshlong/spring-birt'>https://github.com/joshlong/spring-birt</a></p>
;
<p> </p>
</div>
<div>The application is deployed on Windows machine with 12GB of memory</div>
<div> </div>
<div>Detail error msg</div>
<div>
<div>
<div>
<pre class="_prettyXprint">
java.lang.OutOfMemoryError: PermGen space] with root cause
java.lang.OutOfMemoryError: PermGen space
at java.lang.ClassLoader.defineClass1(Native Method)
...
at org.eclipse.birt.spring.core.AbstractSingleFormatBirtView.renderMergedOutputModel(AbstractSingleFormatBirtView.java:399)</pre>
</div>
</div>
</div>
JFreeman
<p>Instead of CATALINA_OPTS, try changing the heap and permgen sizes for JAVA_OPTS in catalina.bat and see if it makes a difference.</p>
Smithdon
<div>setting JAVA_OPTS has no difference.</div>
<div> </div>
<div>Since Permanent Generation (PermGen) space has been removed in HotSpot for JVM 8, I just upgraded to 8 and now it's working.</div>