I tried to move a 6.5SP1 Content Server into a different subnet together with the application server for the web applications. Of course the DNS names are not changed.
But something doesn´t work as expected. Starting the LEMIDB docbase shows the following in the logfile:
Tue Feb 17 15:23:50 2009 547000 [DM_SERVER_I_START_SERVER]info: "Docbase LEMIDB opened"
Tue Feb 17 15:23:50 2009 562000 [DM_SERVER_I_LAUNCH_MTHDSVR]info: "Launching Method Server succeeded."
Tue Feb 17 15:23:50 2009 562000 [DM_SERVER_I_SERVER]info: "Setting exception handlers to catch all interrupts"
Tue Feb 17 15:23:50 2009 562000 [DM_SERVER_I_START]info: "Starting server using service name: dm_LEMIDB"
Tue Feb 17 15:23:54 2009 062000 [DM_SERVER_I_START]info: "Incoming connection backlog set to 200"
Tue Feb 17 15:23:54 2009 078000 [DM_SERVER_I_LISTENING]info: "The server is listening on network address (Service Name: dm_LEMIDB, Host Name: vm_ws_image :V4 IP)"
Tue Feb 17 15:23:54 2009 078000 [DM_SERVER_I_IPV6_DISABLED]info: "The server can not listen on IPv6 address because the operating system does not support IPv6"
Tue Feb 17 15:23:54 2009 078000 [DM_SERVER_I_LISTENING]info: "The server is listening on network address (Service Name: dm_LEMIDB_s, Host Name: vm_ws_image :V4 IP)"
Tue Feb 17 15:23:54 2009 078000 [DM_SERVER_I_IPV6_DISABLED]info: "The server can not listen on IPv6 address because the operating system does not support IPv6"
Tue Feb 17 15:23:54 2009 078000 [DM_SERVER_I_START]info: "Sending Initial Docbroker check-point "
Tue Feb 17 15:23:55 2009 078000 [DM_WORKFLOW_I_AGENT_START]info: "Workflow agent master (tid : 4812, session 019d8eb480000007) is started sucessfully."
Tue Feb 17 15:23:55 2009 344000 [DM_DOCBROKER_I_PROJECTING]info: "Sending information to Docbroker located on host (localhost) with port (1490). Information: (Config(LEMIDB), Proximity(1), Status(Open))."
Tue Feb 17 15:23:56 2009 078000 [DM_WORKFLOW_I_AGENT_START]info: "Workflow agent worker (tid : 5280, session 019d8eb48000000a) is started sucessfully."
Tue Feb 17 15:23:57 2009 078000 [DM_WORKFLOW_I_AGENT_START]info: "Workflow agent worker (tid : 5476, session 019d8eb48000000b) is started sucessfully."
Tue Feb 17 15:23:58 2009 078000 [DM_WORKFLOW_I_AGENT_START]info: "Workflow agent worker (tid : 792, session 019d8eb48000000c) is started sucessfully."
Tue Feb 17 15:24:05 2009 [ERROR] [AGENTEXEC 4720] Detected during program initialization: Command Failed: connect,LEMIDB.LEMIDB,Administrator,'',,,try_native_first, status: 0, with error message [DM_SESSION_E_CLIENT_AUTHENTICATION_FAILURE]error: "Failed to authenticate client. Please check server log for more detail."
.
Tue Feb 17 15:24:05 2009 [FATAL ERROR] [AGENTEXEC 4720] Detected during program initialization: Command Failed: connect,LEMIDB.LEMIDB,Administrator,'',,,try_native_first, status: 0, with error message .
The dm_agent_exec utility is exiting due to a fatal error.
Tue Feb 17 15:25:04 2009 297000 [DM_SESSION_W_RESTART_AGENT_EXEC]warning: "The agent exec program has stopped running. It will be restarted."
This message is repeated in the log.
Clients trying to connect to the Web Application via our Tomcat server have the same problem. Changing the IP back solves the problem. But this is not really an option because the server has to be moved into the new subnet.