Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Opendeploy Base: failed creating socket, got null.
GodBlessMe
Hi we are using OD551. and when we try to deploy content from a workflow i am getting the following error
ENG: 2003-09-24 18:37:51 EDT GMT-04:00 Thread-381 ***ERROR - Job ID=m141Deployment=App1_preview16862
Base: failed creating socket, got null.
OD551 is running on Solaris.
Any help in this regard is highly appreciated.
Find more posts tagged with
Comments
Adam Stoller
Can you run a deployment from the command line?
That error would seem to indicate that the BaseServer is not able to connect to the Receiver - are you sure that the Receiver is running?
--fish
(Interwoven 5.5.2 Certified, Senior Technical Consultant)
GodBlessMe
It is not running from the command line too... WHat could be the possible cause? I guess the receiver is not Up.
What else could cause this problem?
I appreciate your help.
Michael
If the problem is that the BaseServer is not able to connect to the Receiver then any number of things could also be the problem:
- Firewall in the way
- Network cable kicked out
- Connecting on wrong port
- Trying to connect to wrong server
- etc
I would first confirm that OD receiver is running. Then confirm that from your base you can telnet to the receiver on the appropriate port.
hth
Cheers
Michael
GodBlessMe
- Firewall in the way
There is no Firewall between the base and the receiver.
- Network cable kicked out
I can access Other applications running on this server
- Connecting on wrong port
I deployed content to this port recently.
- Trying to connect to wrong server
Adam Stoller
- Connecting on wrong port I deployed content to this port recently.
Define
recently
?
If you cannot run the deployment from the command line either - the problem is either the Base Server or the Receiver, and it sounds very much like the latter.
Can you login to the Receiver server? If so, try running
netstat -na | egrep "9173|20014"
(
assuming you're using port 20014 for deployments
) and verify that the Receiver is, in fact, listening on those ports.
Is the Receiver a multi-IP machine? If so, it may be that the Receiver is binding to the port on on IP and you are attempting to connect to it via a different IP. This happens frequently if you are using hostnames rather than IP-addresses for the
localNode
setting in the
odrcvr.xml
file on the Receiver and for the
host
value in the
odnodes.xml
file on the BaseServer. It could be that the network administrators changed the DNS settings such that the hostname being used now refers to a different IP address when accessed from the BaseServer than it does when accessed from the Receiver.
For checking that - you can usually use
ping
hostname
on both the BaseServer and Receiver, and verify if they both come back with the same IP address. Alternatively (and perhaps more authoritatively) use
nslookup
hostname
from both machines and compare the results.
--fish
Strolling Prime Minister of no fixed address