Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
SP3
khan
TeamSite 552, SP3, Solaris
After upgrading to SP3 about 4-5 weeks ago, we have been experiencing a lot of downtime with our TeamSite server. The server goes down on average once a week, although this did not immediately happen after the install of SP3. It started happening about 1-2 weeks later. 2 out of the 3 or 4 last times that the server went down, after the server was brought up, templating.cfg was somehow corrupted so that we could not edit any dcr's. The error was "Exception while parsing templating.cfg." The corruption was not due to any editing to templating.cfg. We have had to revert templating.cfg back to one version earlier than the version that was live when TS went down, which corrects the problem. Then, we edit templating.cfg to the version that was live when TS went down, and it continues to work.
Has anyone experienced such problems? Any input will help. Thanks!
Find more posts tagged with
Comments
whysguy
Greetings,
As far as the stability of SP3 is concerned, there are about 10 additional patches between templating and teamsite for SP3. Did you install all of the patches as well?
Also, I have seen the exact error you are reporting "Exception while parsing templating.cfg". Unfortunately we were never able to determine the exact root cause of the error. We suspected that there was some invisible character that was causing a problem when parsing, but that was just an educated guess and Interwoven agreed.
We did two things to try to fix/avoid the issue: 1) first we ran the command 'unix2dos' on templating.cfg (I think that is the right command), and 2) from then on we only edited the file in VI directly on the server. I never really felt confident that we new the root cause, or that the problem would never surface again, but we haven't experienced the problem again after taking those steps.
I hope that helps.
- Billy
Migrateduser
first we ran the command 'unix2dos' on templating.cfg (I think that is the right command),
Correction: the name of the utility is
dos2unix
Dave Smith
Sr. Software Engineer
Nike, Inc.
(503) 671-4238
DavidH.Smith@nike.com
khan
So do you attribute this problem with templating.cfg to SP3? We've not had to dos2unix templating.cfg before all this mess. It's only happened after SP3, and templating.cfg is only corrupted after the server has gone down and been brought back up.
I'm not sure that we've applied all the patches you are talking about, but will check with our admin.
whysguy
Our problem wasn't associated with SP3 - we were on SP2 at the time. Also, we never associated the problem as occurring with the server being reset.