Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Odd Deployment Failure
System
ERROR: Deployment (.dartsdeploy_008.com_plus.crp503): Size of local directories[3] is not equal to that of of filelist[2]
ENG: 2003-11-28 09:43:43 EST GMT-05:00 Thread-1509 ***ERROR - Job ID=m781Deployment=dartsdeploy_008
UnSuccessful per-leg after-disconnect DNR Execution ..
any ideas? I'm doing a file list deploy and the file list only contains one file reference ... the path reference is perfectly valid - I don't really understand this error ...
Find more posts tagged with
Comments
Adam Stoller
Might help if you could share more of the log file and/or the deployment configuration.
On off-chance - are you deploying from a workarea, in which other uses may be doing work at the time that you are doing the deployment?
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
Migrateduser
PARAMETERS:
contentServer=crp505,contentDrive=Y,comServer1=crp503,comServer2=crp504,contentArea=WORKAREA/wa,comArea=WORKAREA/wa
MAIN DEPLOYMENT LOG:
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Begin logfile [/opt/OpenDeployNG/log/src.darts_deploy_010.log] ---------
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Job ID=m813 Deployment=darts_deploy_010
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Deployment config file[/opt/OpenDeployNG/conf/darts.xml]
ENG: 2003-11-29 09:17:13 EST GMT-05:00 -----------------------------------------------------------
{?xml version="1.0" encoding="ISO-8859-1"?}
{deploymentConfiguration}
{localNode host="172.16.1.77" /}
{replicationFarmSet}
{replicationFarm name="content"}
{nodeRef useNode="$contentServer^"}
{targetRules area="$contentDrive^:\inetpub\wwwroot\darts"}
{transferRules rmReadOnly="yes"/}
{/targetRules}
{/nodeRef}
{/replicationFarm}
{replicationFarm name="com_plus"}
{nodeRef useNode="$comServer1^"}
{targetRules area="C:\WINNT\System32"}
{transferRules rmReadOnly="yes"/}
{/targetRules}
{/nodeRef}
{nodeRef useNode="$comServer2^"}
{targetRules area="C:\WINNT\System32"}
{transferRules rmReadOnly="yes"/}
{/targetRules}
{/nodeRef}
{/replicationFarm}
{/replicationFarmSet}
{definition name="content"}
{source}
{sourceFilesystem area="/default/main/development/darts/$contentArea^"}
{pathSpecification}
{path name="."/}
{filters}
{excludePath subPath="database"/}
{excludePath subPath="source"/}
{/filters}
{targetRules area="$contentDrive$:\inetpub\wwwroot\darts" /}
{/pathSpecification}
{/sourceFilesystem}
{/source}
{target useReplicationFarm="content"}
{targetFilesystem area="$contentDrive^:\inetpub\wwwroot\darts"/}
{transferRules rmReadOnly="yes"/}
{/target}
{/definition}
{definition name="com_plus"}
{source}
{sourceFilesystem area="/default/main/development/darts/$comArea^/source/build" filelist="/default/main/development/darts/$comArea^/source/build/darts_pre_install.lst"}
{pathSpecification}
{path name="."/}
{filters }
{includePath subPath="darts_pre_install.vbs"/}
{/filters}
{targetRules area="C:\WINNT\System32"}
{filters }
{includePath subPath="darts_pre_install.vbs"/}
{/filters}
{/targetRules}
{/pathSpecification}
{/sourceFilesystem}
{sourceFilesystem area="/default/main/development/darts/$comArea^/source/build"}
{pathSpecification}
{path name="."/}
{filters }
{excludePath subPath="darts_pre_install.vbs"/}
{excludePath subPath="darts_install.vbs"/}
{excludePath subPath="darts_pre_install.lst"/}
{excludePath subPath="darts_install.lst"/}
{/filters}
{targetRules area="C:\WINNT\System32"/}
{/pathSpecification}
{/sourceFilesystem}
{sourceFilesystem area="/default/main/development/darts/$comArea^/source/build" filelist="/default/main/development/darts/$comArea^/source/build/darts_install.lst"}
{pathSpecification}
{path name="."/}
{filters }
{includePath subPath="darts_install.vbs"/}
{/filters}
{targetRules area="C:\WINNT\System32"}
{filters }
{includePath subPath="darts_install.vbs"/}
{/filters}
{/targetRules}
{/pathSpecification}
{/sourceFilesystem}
{/source}
{target useReplicationFarm="com_plus"}
{targetFilesystem area="C:\WINNT\System32"/}
{transferRules rmReadOnly="yes"/}
{/target}
{/definition}
{deployment transactional="no"}
{execDeploymentTask useDefinition="content"/}
{execDeploymentTask useDefinition="com_plus"}
{deployNRun}
{dnrFile location="target" when="after" state="always" mask="darts_pre_install.vbs" }
{script cmd="C:\WINNT\System32\cscript.exe C:\WINNT\System32\darts_pre_install.vbs" async="no"/}
{/dnrFile}
{dnrDeployment location="target" when="after" triggerPoint="transfer" state="always"}
{script cmd="C:\WINNT\System32\cscript.exe C:\WINNT\System32\darts_install.vbs" async="no"/}
{/dnrDeployment}
{!--
{dnrFile location="target" when="after" state="always" mask="darts_install.vbs" }
{script cmd="C:\WINNT\System32\cscript.exe C:\WINNT\System32\darts_install.vbs" async="no"/}
{/dnrFile}
--}
{/deployNRun}
{/execDeploymentTask}
{/deployment}
{/deploymentConfiguration}
ENG: 2003-11-29 09:17:13 EST GMT-05:00 -----------------------------------------------------------
ENG: 2003-11-29 09:17:13 EST GMT-05:00 End of deployment config file[/opt/OpenDeployNG/conf/darts.xml]
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Simulate flag = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Synchronous flag = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Start perform internal conversion for: /opt/OpenDeployNG/conf/darts.xml
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Finished conversion for: /opt/OpenDeployNG/conf/darts.xml
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Quorum flag = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Target Area is Y:/inetpub/wwwroot/darts
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Next deployment flag for crp505 = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Internal deployment name is .darts_deploy_010.content.crp505
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Got internal config file for .darts_deploy_010.content.crp505
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Quorum flag = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Target Area is C:/WINNT/System32
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Next deployment flag for crp503 = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Internal deployment name is .darts_deploy_010.com_plus.crp503
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Got internal config file for .darts_deploy_010.com_plus.crp503
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Next deployment flag for crp504 = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Internal deployment name is .darts_deploy_010.com_plus.crp504
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Got internal config file for .darts_deploy_010.com_plus.crp504
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Parent deployment multi-tier flag = false
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Starting internal deployment crp505.content, Thread-1563
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Starting internal deployment crp503.com_plus, Thread-1564
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Starting internal deployment crp504.com_plus, Thread-1565
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Waiting for 3 children to complete phases
ENG: 2003-11-29 09:17:14 EST GMT-05:00 No of children = 3, failed = 2, redirected = 1
ENG: 2003-11-29 09:17:14 EST GMT-05:00 All 3 children completed their phases
ENG: 2003-11-29 09:17:14 EST GMT-05:00 EXITING [setup] ENTERING [cleanup]
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Completed session queue capacity reached. Removed oldest session.
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Job ID=m813 Deployment=darts_deploy_010 Elapsed Time=1066 ms {{{
ENG: 2003-11-29 09:17:14 EST GMT-05:00 End logfile [/opt/OpenDeployNG/log/src.darts_deploy_010.log]
FAILED DEPLOYMENT LOG:
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Begin logfile [/opt/OpenDeployNG/log/src.darts_deploy_010.com_plus.nsun705.to.crp503.log] ---------
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Job ID=m813 Deployment=darts_deploy_010
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 OpenDeploy Version is 5.6.0.1.0
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Owner started the deployment is a100166
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Internal config file [/opt/OpenDeployNG/etc/.darts_deploy_010.com_plus.crp503]
ENG: 2003-11-29 09:17:13 EST GMT-05:00 -------------------------------------------------
deployment_name=.darts_deploy_010.com_plus.crp503
hostname=172.16.1.77
remote_server=172.16.2.83
remote_port=20014
buffer_size=8000
verbose_level=5
do_manifest_for_dnr
deployment=.darts_deploy_010.com_plus.crp503
file_list=/default/main/development/darts/WORKAREA/wa/source/build/darts_pre_install.lst
area=/default/main/development/darts/WORKAREA/wa/source/build
local_directory=.
source_include=darts_pre_install.vbs
destination_include=darts_pre_install.vbs
rm_readonly
ignore_acls
remote_directory=C:/WINNT/System32
;
area=/default/main/development/darts/WORKAREA/wa/source/build
local_directory=.
source_exclude=darts_pre_install.vbs
source_exclude=darts_install.vbs
source_exclude=darts_pre_install.lst
source_exclude=darts_install.lst
rm_readonly
ignore_acls
remote_directory=C:/WINNT/System32
;
file_list=/default/main/development/darts/WORKAREA/wa/source/build/darts_install.lst
area=/default/main/development/darts/WORKAREA/wa/source/build
local_directory=.
source_include=darts_install.vbs
destination_include=darts_install.vbs
rm_readonly
ignore_acls
remote_directory=C:/WINNT/System32
;
deploy_run_script=C:\WINNT\System32\cscript.exe C:\WINNT\System32\darts_pre_install.vbs
async=no
where=
as=
when=server_after_file on_success on_failure
file_mask=darts_pre_install.vbs
;
deploy_run_script=C:\WINNT\System32\cscript.exe C:\WINNT\System32\darts_install.vbs
async=no
where=
as=
when=server_after_deploy on_success on_failure
;
;
ENG: 2003-11-29 09:17:13 EST GMT-05:00 -------------------------------------------------
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 End of internal config file [/opt/OpenDeployNG/etc/.darts_deploy_010.com_plus.crp503]
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 exiting initial
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 entering setup
LIB: LOGFILE=[/opt/OpenDeployNG/log/src.darts_deploy_010.com_plus.nsun705.to.crp503.log]
LIB: Locale=[English_UnitedStates.US-ASCII@Binary]
ERROR: Deployment (.darts_deploy_010.com_plus.crp503): Size of local directories[3] is not equal to that of of filelist[2]
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 ***ERROR - Job ID=m813Deployment=darts_deploy_010
UnSuccessful per-leg before-connect DNR Execution ..
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Connecting to host=172.16.2.83 port=20014
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 After Connect RC = 0
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Sender-side handshake timeout = 120 secs
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Send version string to receiver, RC = 13
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Send attributes to receiver, RC = 1
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Read attributes from receiver.
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 sender-version=5.6.0.1.0 receiver-version=5.6.0.1.0
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Sender is version master
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Sender compatible with receiver: version same
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 Sender profile
#session properties
#Sat Nov 29 09:17:13 EST 2003
TARGETAREA=C\:/WINNT/System32
ODADAPTERSET=
DEPLOYNAME=darts
DEPUUID=darts_deploy_010.m813.Sat_Nov_29_09\:17\:13_EST_2003
JOBID=m813
DEFNAME=com_plus
DEPLOYTYPE=103
DESCRIPTION=
DEPLOYSUFFIX=_deploy_010
OWNER=a100166
SYNCHRONIZEPHASE=false
SOURCEHOST=nsun705
TRANSACTIONAL=false
COMPRESSION=false
VERSION=5.6.0.1.0
LEGID=crp503
TARGHOST=172.16.2.83
SYNCH=false
VERIFYPHASE=false
REVERSE=false
LOGLEVEL=VERBOSE
LIB: LOGFILE=[/opt/OpenDeployNG/log/src.darts_deploy_010.com_plus.nsun705.to.crp503.log]
LIB: Locale=[English_UnitedStates.US-ASCII@Binary]
ERROR: Deployment (.darts_deploy_010.com_plus.crp503): Size of local directories[3] is not equal to that of of filelist[2]
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 After SETUP, res=-1
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 exiting setup
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 entering awaiting-cleanup
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 exiting awaiting-cleanup
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 entering cleanup
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 After CLEANUP, res=-1
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 exiting cleanup
ENG: 2003-11-29 09:17:13 EST GMT-05:00 Thread-1564 entering task-failed
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Thread-1564 still waiting for 1
LIB: LOGFILE=[/opt/OpenDeployNG/log/src.darts_deploy_010.com_plus.nsun705.to.crp503.log]
LIB: Locale=[English_UnitedStates.US-ASCII@Binary]
ERROR: Deployment (.darts_deploy_010.com_plus.crp503): Size of local directories[3] is not equal to that of of filelist[2]
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Thread-1564 ***ERROR - Job ID=m813Deployment=darts_deploy_010
UnSuccessful per-leg after-disconnect DNR Execution ..
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Thread-1564 Deleting the internal config file = /opt/OpenDeployNG/etc/.darts_deploy_010.com_plus.crp503
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Thread-1564 Job ID=m813 Deployment leg=crp503.com_plus Elapsed Time=1109 ms {{{
ENG: 2003-11-29 09:17:14 EST GMT-05:00 Thread-1564 End logfile [/opt/OpenDeployNG/log/src.darts_deploy_010.com_plus.nsun705.to.crp503.log]
Need anything else?
Adam Stoller
Does the filelist (darts_pre_install.lst) contain just a list of files, or are some of the entries just directory paths?
While I've never (to my recollection) seen that specific error before
-------------
ERROR: Deployment (.darts_deploy_010.com_plus.crp503): Size of local directories[3] is not equal to that of of filelist[2]
-------------
You *are* deploying from a workarea, and it looks a lot like the kind of error that happens when you're deploying a file from a workarea and the contents of the file changes inbetween an initial stat and the actual deployment.
Looking at your config a little closer - for the first part of the com_plus definition, I think you want *either* a filelist *or* an includePath (or includePattern) filter - I don't think you need both. Though I don't think this is the source of your current error.
I'm assuming that C:\WINNT\System32 is an allowed directory path for node "172.16.1.77" on Receiver "crp505" - yes?
I think you're probably going to have to work through this problem with Interwoven Support...
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com