Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Comparing with INITIAL EDITION fails
polo
Hi Folks,
For deploying all the contents, we are comparing Current Edition and Initial Edition. But this is giving us error. Please refer to the code and Error below:
<deploymentConfiguration nodeSetFile="/usr/iw-home/OpenDeployNG/etc/odnodes.xml" >
<localNode host="appserver1123" />
<replicationFarmSet >
<replicationFarm name="prodappserver" quorum="3" >
<nodeRef useNode="a" />
<nodeRef useNode="b" />
<nodeRef useNode="c" />
</replicationFarm>
</replicationFarmSet>
<definition name="prodappserver_deployment">
<source>
<sourceTeamsite area="/default/main/COMPROD/EDITION" previousArea="/default/main/COMPROD/EDITION/INITIAL">
<pathSpecification>
<path name="appserver" />
</pathSpecification>
</sourceTeamsite>
</source>
<target useReplicationFarm="prodappserver" >
<comparisonRules dateDifferent="yes" />
<transferRules dontDo="yes" />
<permissionRules file="0644" directory="0755" user="COMPROD" group="COMPROD"/>
<targetFilesystem area="/www/weblogic/6.1/COMPROD2/applications" />
</target>
</definition>
<deployment transactional="yes" >
<execDeploymentTask useDefinition="prodappserver_deployment" />
</deployment>
</deploymentConfiguration>
ERROR in opendeploy Logs:
client: Options: user=COMPROD group=COMPROD file_perm=0644 dir_perm=0755 date_different dont_do
(2) client: [Tue Dec 16 10:11:59 2003] Comparing path[/default/main/COMPROD/EDITION/ed_20031216-101136/appserver] with prev path[/default/main/COMPROD/EDITION/INITIAL/appserver]
(3) client: Walking TeamSite directory[.]
ERROR: Error locating /default/main/COMPROD/EDITION/INITIAL/appserver/.
Any Comments??
Thanks and Regards
Pankaj
Find more posts tagged with
Comments
Adam Stoller
Hmm - I think this is an old problem that [I guess] is still around in 5.x. OpenDeploy gets confused when performing a comparison against the INITIAL [*empty*] edition.
Two things:
1) What happens if you actually try the deployment (rather than running with dontDo enabled as you have it)?
2) Do you really want to deploy *every* asset *every* time you run this deployment? Using sourceFilesystem or keeping track of last-edition deployed and using that as the previousArea in a sourceTeamsite deployment are generally better alternatives (though you still might have a problem with the first such deployment?)
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
polo
Thanks for reply.
I modified the sourceTeamsite tag as:
<sourceTeamsite area="/default/main/MyOnStar/EDITION/$editionname" >
where I am passing parameter, $editionname as latest edition name.
With date comparison, will this deploy the modified contents to the target server ?
Thanks and Regards
Pankaj
Migrateduser
Take a look at the OD 5.6 Admin Guide (Nov 2003 edition) page 115. There it says "If you are deploying the entire contents of the source TeamSite area by specifying the previousArea attribute location as an empty TeamSite area (such as the initial edition that is generated for the TeamSite base branch (EDITION/INITIAL)), the path element’s name attribute value can only be "." No other locations can be specified."
Looks like the path you specified is not ".".
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
Adam Stoller
Ahhh - yes, I missed that in the initial code posting. Good catch Todd!
Polo - sourceTeamsite *requires* a previousArea to be specified, so your modification would not work.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com